Suzuki SV650 Riders Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
where can i find a 2007 sv1000s repair manual? not the owners manual

because my engine is backfiring through the intake making a really loud pop and it scares me to ride it like that. my mechanic couldnt fix it, this is my second bike. i was dumb enough to buy it, it was dropped hard from the last owner.
 

·
Registered
Joined
·
391 Posts
where can i find a 2007 sv1000s repair manual? not the owners manual

because my engine is backfiring through the intake making a really loud pop and it scares me to ride it like that. my mechanic couldnt fix it, this is my second bike. i was dumb enough to buy it, it was dropped hard from the last owner.
I think thats a common problem. Mine pops but only through the exhaust occasionally on deceleration. Doesnt bother me. Try this http://www.holeshot.com/sv650/decel.html or google pair system removal.

You might have your intake de snorkled and thats why its popping through it. Just get a used stock snorkel and it should fix it, maybe........
 

·
Registered
Joined
·
223 Posts
Repair manual is online somewheres, if you need I can email you the separate parts of it (the factory service manual that is). The backfire happens on mine too on deceleration. De-snorkeled, Hindles, PC3. I've heard of the PAIR mod as well and will probably take it in to a shop to actually get it tuned properly.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
Repair manual is online somewheres, if you need I can email you the separate parts of it (the factory service manual that is). The backfire happens on mine too on deceleration. De-snorkeled, Hindles, PC3. I've heard of the PAIR mod as well and will probably take it in to a shop to actually get it tuned properly.
i know about the decelerating backfiring through the exhaust. it happens on my 650 and it's fine, i know it's normal. but this problem i have definitely isnt normal. it only happens when im under a certain RPM like 2-3, putting it into first gear and accelerating slowly, or when im in neutral and playing with the throttle reving it slowly, then POP under the gas tank. it's loud and it rattles the gas tank.
 

·
Premium Member
Joined
·
2,041 Posts
Try google pair system removal.

You might have your intake de snorkled and thats why its popping through it. Just get a used stock snorkel and it should fix it, maybe........
Pair is exhaust side, he is having popping on the intake side. Check the Pair hoses to the airbox though for good connections.

You said bike was dropped hard. Hard doesn't matter, check for oil in the airbox and the connections, but you could also be running lean. To determine how lean, you could have a vapor test done and have a remapping done.

Post up your mod list in the tech forum thread that you created so we can continue to help you there, without the need to cross post ...ie, desnorkel, aftermarket cans, TRE, Pair Removal, STV adjustments...etc

The manual isn't going to troubleshoot moddings by previous owners, but will be good for you to have overall.

i know about the decelerating backfiring through the exhaust. it happens on my 650 and it's fine, i know it's normal. but this problem i have definitely isnt normal. it only happens when im under a certain RPM like 2-3, putting it into first gear and accelerating slowly, or when im in neutral and playing with the throttle reving it slowly, then POP under the gas tank. it's loud and it rattles the gas tank.
The 1K is a totally different beast than the 650 and it is more common than you think.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #7 ·
everything on the bike is stock throttlebody. should i still post this problem up on the tech forum?
 

·
Premium Member
Joined
·
2,041 Posts
I was referring to the post you had originally created there. I will post a link in the original, pointing to the new one with the information you posted, that way, we can keep track better of what you are checking. Hopefully, we can get this resolved.
 

·
Registered
Joined
·
818 Posts
everything on the bike is stock throttlebody. should i still post this problem up on the tech forum?
Why not start a thread in every single section on the forum? You only have three ongoing threads on the same subject so far. :facepalm:
 

·
Premium Member
Joined
·
2,041 Posts
I got a little confused when I saw the 3rd one started above the 1st one in the workshop forum.....lol

Sent from my right shoe phone.
 
1 - 11 of 11 Posts
Top