Suzuki SV650 Riders Forum banner

14621 - 14640 of 15863 Posts

·
Registered
Joined
·
465 Posts
Changed the front tire on the ZX today, took a while (aka huge PITA) but now there is a brand new Battlax T30 on it that will hopefully be there for a while! ;D
 

·
Registered
Joined
·
966 Posts
On Saturday I brought home a buddy for it! Unfortunately that buddy is it's replacement. SV is for sale and have had a few CL hits. We'll see how they pan out. I'll certainly miss the SV but I can't do insurance on both of them.

2013 Speed Triple R ABS. 4,500 Miles. Full 3 to 1 Arrow exhaust. Just need a Tail Tidy/remove the rear pegs and I'll be set.

Put on some miles yesterday. Man this bike is fun!



 

·
Premium Member
Joined
·
2,103 Posts
Had to leave it at my parents house.........

:-(

My wife was stung by three wasps and is apparently allergic. Sore and has 'limp arm syndrome' lol.
 

·
Super Moderator
Joined
·
6,776 Posts
Got the front end of the project bike together.


Replaced the broken gauges. Pulled the new one apart and cleaned the glass, painted the chrome back covers, and removed the faux carbon overlay around the tach. Powder coated the upper triple, levers, bars, headlight ring, and headlight mounts. Also cut some "speed holes" in the headlight mounts and added some smaller signal (and tinted the lenses). Had some custom small barends made and coated them also.







I'm working on fixing the damaged tank I got with it. It had been dropped on the left side, and somebody "fixed" the dent with about an inch of filler. I have the tank stripped and the dent almost completely roughed-out, but there is still plenty of work needed.

The original plan was for satin charcoal on the wheels and frame and orange on the bodywork, but we may be changing that to solid bright "Suzuki Blue" on the wheels and bodywork. Frame and swingarm will most likely still be satin charcoal - but that's another project. Plan to get it on the road and running well before completely disassembling it...
 

·
Premium Member
Joined
·
2,103 Posts

·
Premium Member
Joined
·
3,055 Posts
removed front sprocket cover to prepare for new sprockets and chain installation.
Jesus what a mess. Not touched in 20K and using oil to lube my chain. You can imagine
 

·
Premium Member
Joined
·
3,055 Posts
^ A BIG can of WD-40 is your friend.....
It really was awful. I really should include a cleaning or two into the last 10K miles on a chain, especially as I use motor oil for lube, and lube after every ride basically.

I didn't have any degreaser handy, so I basically scraped it off and then wiped.

Good news is that neither my clutch pushrod seal or countershaft seal are leaking.

Bad news is that I am starting to lose oil (about 1/2 qt every 1500 miles) and with no physical leaks, that most likely means worn valve guides just like motor #1.

It's cheaper to slap another motor in there than to have the top end rebuilt.

That's a project for this Winter, so for now I will just put up with the oil loss. Bike is still running pretty well (over 95K miles on this motor...never had valves even checked)

Motor #3 is being searched for.
 

·
Registered
Joined
·
222 Posts
Swapped in some Sonic Springs to the forks, new tires are being put on tonight. Just need to re-install the forks, install the new stainless lines and she'll be back in action.
 

·
Registered
Joined
·
53 Posts
Ordered a few parts; New front tire, Flush mount front turns, integrated rear, four six inch LED strips to add some extra hidden turn signal lighting.
Also took off the passenger pegs after riding without a muffler for a couple days. It's addictive, but I'm sure it will get annoying soon. Going to fab up a bracket that doesn't require the peg.
 
14621 - 14640 of 15863 Posts
Top