Suzuki SV650 Riders Forum banner

13981 - 14000 of 15863 Posts

·
Registered
Joined
·
205 Posts
Technically last night, but finished up today. got my new tire on. cleaned and waxed the chain, and installed new rear brake pads. hopefully that will take care of the squeaking when I stop.


Also I pulled the front sprocket cover and found a ton of crud built up in it, started pulling it out and noticed a ton of gunked up little o-rings. anybody have a clue what these could be from?
 

·
Registered
Joined
·
324 Posts
Glued my brake lever( front and back) back till I receive new lever , dropped the bike at 2mph yesterday because of my passenger , tried to do a close turn ( as I normally do alone) and she moved from her seat at the same time , steering went at the end and I wasn't able to hold the weight because my right leg is not 100% strong

Exhaust and bar end are now scratched , and both lever broke , rear is unusable but front only lost the ball at the end of the lever , still went home after ..


Sent from Motorcycle.com Free App
 

·
MOTORADOR
Joined
·
10,780 Posts
Also I pulled the front sprocket cover and found a ton of crud built up in it, started pulling it out and noticed a ton of gunked up little o-rings. anybody have a clue what these could be from?
That can only come from a chain gone VERY bad.
 

·
Registered
Joined
·
108 Posts
installed an undertail and a buncha wiring...flush front turn signals, new tailight with integrated turns, new plate light...shorty levers, fixed rate flash relay, hookup for my battery tender, few other things...
 

·
Registered
Joined
·
1,098 Posts
Replaced a dead battery (Autocraft 14-BS) with an EverStart ES12BS from Walmart...I'm hoping this battery will hold up. The Autocraft lasted a bit over 3 years.

I also bought a ReChargeiT 8 amp charger/maintainer for a good price. I didn't have to wait long for the new battery to charge (1.5 hrs).

I was going to ride today, but the bike was sputtering to the point that it was almost dangerous to ride. A cylinder kept cutting out. I looked at the front wire and found that it was completely off the plug but was apparently flailing around the plug well and making intermittent contact with the plug. Kinda weird that it came off, but I guess it vibrated off. That would be a pain in the ass to fix on the side of the road with a hot engine.
 

·
MOTORADOR
Joined
·
10,780 Posts
Installed a new chain. It's gold.
Congratulations, you have automatically qualified to be part of the douchebag club. :buddies:
 

·
Registered
Joined
·
18 Posts
Finished install of lower fairings, cleaned up the chain and rode it to and from work for the first time in a while. Was a great ride and made me realize I had been missing out by mainly driving my car. So unlike me.
 

·
Greetings Program
Joined
·
6,272 Posts
Yesterday: Re-routed some electrical wires for my cell charger and battery tender hookup. Cleaned everything under the seat & tank. Checked air filter. Adjusted throttle cable slack (Very nice having it up snug). Replaced a missing bolt on my tail light/plate bracket.
 

·
Registered
Joined
·
108 Posts
installed zx14 shock, pulled the forks and cleaned up the chrome (got mine from a buddy who lived by the ocean for awhile) and swapped to racetech 1.0s and 15w belray...wanted to paint the lowers black but i need my bike ready tomorrow so i'll just have to paint em later...cleaned and lubed the chain, popped on a smoked d-bubble screen
 
13981 - 14000 of 15863 Posts
Top