Suzuki SV650 Riders Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello, I am a new owner to a 2004 sv650s. When i went down to start it today the red check light came on and it wont let me start it up. There are no leaks and all lights still turn so i don't believe it is the battery either. What is a good starting point to figure out the problem?
 

·
Registered
Joined
·
69 Posts
your bike is not in neutral, or the kill switch is in the incorrect position.

Do you hear the fuel pump turn on when you turn the key?
 

·
Registered
Joined
·
217 Posts
As said before, the Check Engine light is always lit with FI on the LCD until the bike is running.

Things to check: clutch switch - clutch engaged to start, kickstand switch - bike will not start/run with kickstand down unless in neutral, and fuses.
 

·
Premium Member
Joined
·
3,662 Posts
As said before, the Check Engine light is always lit with FI on the LCD until the bike is running.

Things to check: clutch switch - clutch engaged to start, kickstand switch - bike will not start/run with kickstand down unless in neutral, and fuses.

Or the start switch... the guy I bought the bike off always shut the bike off with the key only... and I do the switch on the bar, then the key...

So when I test drove it, I killed it my usual way... then the next day when he went to move it, he said he was in a panic because it wouldn't start....

Eventually he noticed the switch ;D

Not saying it is the case here.. but sometimes it happens :p


As mentioned it sounds like either the clutch switch is stuckl, or it is in gear the side stand, or the side sensor is stuck or malfunctioning... (happens when you ride on crap roads, it gets caked in road salt and dries stuck as you ride... then when you get off it doesn't pop back out all the way)
or the switch, or the clutch switch...

if you don't hear the FI prime it is probably something with the bar switch...
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Well, I figured out the problem. Evidently a buddy of mine had gone down to check out my bike and had switched gears all the way up to sixth some how. I was unable to get it all the way back down to neutral earlier but was able to get it down far enough for the fuel injection to kick in and start it without the green light on let it run and put it into neutral. It seemed fine after that. Appreciate everyone's help, haha, I'm sure I'll have another dumb question in the future.
 

·
Registered
Joined
·
181 Posts
Well, I figured out the problem. Evidently a buddy of mine had gone down to check out my bike and had switched gears all the way up to sixth some how. I was unable to get it all the way back down to neutral earlier but was able to get it down far enough for the fuel injection to kick in and start it without the green light on let it run and put it into neutral. It seemed fine after that. Appreciate everyone's help, haha, I'm sure I'll have another dumb question in the future.
Friends. :angry1:
 
1 - 8 of 8 Posts
Top