Suzuki SV650 Riders Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Tried doing the clutch mantra and messed with the adjustor screw to get a more positive catch with my gears. Now I can shift into first and all other gears for that matter with out pulling my clutch lever.

I've completely removed the clutch lever to make sure there was nothing puuling on the clutch cable. Ive screwed the adjustor screw all the way out and in untill there arent anymore thread to put the lock nut on but that still makes no difference.

Everything seems to work just fine for normal riding. like i can pull in the lever and my bike wont stall. but with out the lever pulled in i can put minimal pressure on the foot controls and it will start to click/grind. put more pressure on it and it will go into first with out pulling the clutch lever and my bike will lunge and die. I can also do clutchless shifting now throughout a ride. I don't want that though. Will this cause wear and tear to the clutch do to it not fully engaging?

How do I fix this?
 

· Registered
Joined
·
23 Posts
Discussion Starter · #3 ·
I tried to tighten it untill i felt the light resistance and backed it out a little. it doesnt change anything. still acts like it isnt fully engaged. before i tried to adjust it i never could clutchless shift. too much resistance. now it'll go into gear super easy. i mean super super easy. if its not going to hurt anything then ill just keep it like it is until the next service. but im scared that if its not fully disengaging that ill just be doing more than normal wear to the clutch.
 

· Registered
Joined
·
23 Posts
Discussion Starter · #6 ·
Finally took my bike out for a real ride up to the mountains. Tried adjusting the push rod screw under the sprocket cover before the ride but the clutch was still acting the odd. It does seem as though my revs are not matching my speed. I noticed that when I was accelerating my revs would remain at about 7k as i switched from 1st to 2nd and 3rd. No real deviation from 7k as my bike accelerated until i went into 4th and on then is seemed to match normal revs.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top