Suzuki SV650 Riders Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter #1
Ok so I did the TPS mod yesterday on my 07. Had no idea it would be so different from the 04 that the guide folks from here linked to.

Supposed to be a 20 min job, wasn't.

Got seats all off and tank up, ready to rock. First thing, 07's dealer mode plug nowhere near where that guy found it. Mine was close to the battery right about directly underneath the part of the frame that seperates the front and back seats. (+15mins)

Tried paperclip to jump the plug, no go, went down found some old speaker wire and used that. (+15mins)

Got it in dealer mode and like he said the line didn't move till almost 4k. Ok next step check the idle. Bottom left side of airbox ... no idle adjustment. WTF?? Started pulling caps off stuff still no hidden idle control. Looked for 15mins or so then went inside and hopped on the net to discover theres no idle adjustment on the 07 & 08's. LAME! (+20mins)

Ok time to find the TPS. Looking for 2 size 25 security torx bits over a round sensor. Hmmm... nothing like that here. Long story short theres only 1 screw on the 07 and the sensor looks different. (+20 mins)

Hard to adjust without being able to adjust idle. Killed it a few times but eventually just barely loosend the screw so that with a good amount of pressure I could move it a tiny bit. Was able to get it so the top line was hitting just past idle (around 1300) (+25mins)

As I was making the final tighten on the torx screw, bit pops out of the ratchet and is somehow eaten by the bike. (looked everywhere, shook the hell outs the bike side to side, nothing. grrr) (+45mins of SAR no R)

So anyway its done. Heres my question. Everything I read was saying you want the line to go from mid position to top around 1450ish RPMS. Mine is 1300, will that cause any problems otjher than gas mileage? I can already tell that it did work as far as the ****** throttle response I was getting in low speed low gear. I just want to make sure there isn't some unintended consequence of having it trip just past idle.

Thanks
 

·
Registered
Joined
·
108 Posts
Discussion Starter #3
Right I know its a bit low just above idle, my question is will it cause any problems being there?
 

·
Registered
Joined
·
2,849 Posts
If the TPS is set too close to idle it will cause the bike to shut off like you saw when you were adjusting that. Wait till a cold morning and start the bike. The 07's idle is electronically controlled, meaning if the bike is cold it will fast idle to stay running for the first minute or so. If you try to start it and it keeps dying, you set the TPS too close.
 

·
Registered
Joined
·
108 Posts
Discussion Starter #5
If the TPS is set too close to idle it will cause the bike to shut off like you saw when you were adjusting that. Wait till a cold morning and start the bike. The 07's idle is electronically controlled, meaning if the bike is cold it will fast idle to stay running for the first minute or so. If you try to start it and it keeps dying, you set the TPS too close.
Thanks, thats what I was kind of noticing. It felt like the idle was adjusting slightly to where the TPS was at everytime I shut it off.

The last time it seemed to be idling a touch low but the TPS was where I wanted it, then I turned it off and when I restarted it the idle was fine and the slightest touch of the throttle caused the line to go up. Which is what I was after I believe. I did let it run for another 20 mins reving it occasionally to make sure nothing wierd happened and all seemed fine.
 

·
Registered
Joined
·
2,849 Posts
You do want it close, but not too close. That's why it's recommended to be set closer to 1450.
 
1 - 6 of 6 Posts
Top