Suzuki SV650 Riders Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
242 Posts
Discussion Starter #1
Put heaters under my grips last season and when I rode in this AM the throttle tube was sticking. I would rev and it would sloooooowly return back. Anyone else have this problem and/or what can I do??
 

·
Registered
Joined
·
128 Posts
Take off the bare ends and trim that rubber piece on the end of the grips, thats if you have oxford....If you have another brand-you might have gotten glue in a spot that it interferes with the trottle returning smoothly..Tom
 

·
Registered
Joined
·
1,220 Posts
I'd say check to make sure that the tube hasn't migrated on the bar. Maybe it's binding on the bar end weight? Or it might be that the cables somehow got kinked?
 

·
Registered
Joined
·
905 Posts
Not to insult your intelligence, but you did install the throttle side grip warmer on the plastic of the throttle tube and not the metal of the actual bar, correct?


If so, follow the above posted suggestions and check:

throttle tube not binding on bar end

wires from grip heater not binding or throttle tube rubbing against them

throttle cables not binding or routing of cables changed when you installed the grip heaters
 

·
Registered
Joined
·
242 Posts
Discussion Starter #5
I installed it on the plastic I believe, because I don't remember taking the throttle tube off at all. I will check for where it is binding.
 

·
Registered
Joined
·
3,483 Posts
Your heating element got too hot and deformed your throttle tube or grip. Mine is like that right now(along with a melted grip). You could take off the throttle assembly and spray some lube between the tube and bar.
 
1 - 6 of 6 Posts
Top