Suzuki SV650 Riders Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1 (Edited)
My bike seems to leak oil ONLY when I do a wheelie (power of clutch) or when Im really pushing it and reving high. If I just cruise around normally it wont leak. The leak is coming from the left side, near the clutch slave cylinder. It is leaking motor oil, its not clutch fluid and its not chain lube. I brought it into a local shop and they said it was leaking from from the clutch shaft seal. They said it was leaking from a seal around the clutch push rod, not the seal on the slave cylinder but on the transmission I guess. Anyways, they replaced it and I took it home and its still leaking. I already called the shop and they told me to bring it back, but Im just looking for any more opinions.

Again, it is leaking motor oil form somewhere ont he left side up near the transmission and slave cylinder. It is not the oil filter or the drain plug and its not chain lube. What are some possible or common leaks in that area?

Its leaking from some where up in that crevice below the slave cylinder.


 

·
Premium Member
Joined
·
3,311 Posts
this should be interesting......
 

·
Registered
Joined
·
17,602 Posts
Clean your engine really well. Scrub it clean.

Dry it.

Go buy an aerosol deoderant. Make sure it has talcum (baby) powder in it.

Spray it heavily ALL over the underside of the bike. HEAVILY. You should see WHITE every where.

Go ride the bike hard on a clean road for a few miles. Go back home. Look for the wet spots.

There's your leak.
 

·
Registered
Joined
·
589 Posts
Clean your engine really well. Scrub it clean.

Dry it.

Go buy an aerosol deoderant. Make sure it has talcum (baby) powder in it.

Spray it heavily ALL over the underside of the bike. HEAVILY. You should see WHITE every where.

Go ride the bike hard on a clean road for a few miles. Go back home. Look for the wet spots.

There's your leak.

Wow what a good Idea !!! and I thought it would only work on fat chicks.... Opps did I say that out loud?
 

·
Registered
Joined
·
45 Posts
i had an 03 sv1k and it did the same thing. I think you have to retorque, or if that doesnt work, re gasket, the thingy down there where its leaking from. Clutch cover I think? I sold the bike however.
 
1 - 16 of 16 Posts
Top