Suzuki SV650 Riders Forum banner

721 - 740 of 740 Posts

·
Registered
Joined
·
17,602 Posts
Discussion Starter #724
A bit of progress this afternoon.

I modded the lamp housing to accept a 2500 lumen, 1.6 amp LED bulb. It's a new headlamp bucket, too. I was worried it would be too big, but once mounted, its size matches the lines of the bike AND it accidentally matches the turn signals.















I also fabbed a simple bracket to hold my hi-beam, oil pressure, and neutral indicator LED's, but need to make another because I forgot to incorporate my charging system LED and the hi/low beam switch.

It was simple, though, just a piece of 3/16" flat bar stock, so making another will be easy to do.

 

·
Premium Member
Joined
·
5,615 Posts
Haha, I was thinking just yesterday that I should bump this thread!
 

·
Registered
Joined
·
17,602 Posts
Discussion Starter #732
I finally got to this point. The bike is almost done. Since making this video this weekend, I've connected the tach and set the idle speed to around 1200rpm. In this video, it's too low.

I've also put the seat on, nearly finished the wiring, and retorqued the heads. Only a few things are needed to get it road worthy--fork oil, brake/clutch/speedo cables, mount the brake light, and a few small odds and ends.

 

·
Registered
Joined
·
2,364 Posts
I finally got to this point. The bike is almost done. Since making this video this weekend, I've connected the tach and set the idle speed to around 1200rpm. In this video, it's too low.

I've also put the seat on, nearly finished the wiring, and retorqued the heads. Only a few things are needed to get it road worthy--fork oil, brake/clutch/speedo cables, mount the brake light, and a few small odds and ends.
Only another 5 to 8 years and it'll be roadworthy.
 

·
Registered
Joined
·
17,602 Posts
Discussion Starter #735
5-8 weeks my ass.

It sat for two years because life got in the way. I finally got it good enough to ride up the driveway and back, so that's something.

My parents came to visit and I wanted him to see it ridden. No rear brake right now, the auxiliary tank looks like an I.V. drip, and the clutch is slipping, but it goes under its own power.

Tank is currently being painted. It'll FINALLY be done soon.

https://youtu.be/JqTyVotC1Z0
 

·
Registered
Joined
·
17,602 Posts
Discussion Starter #740
https://youtu.be/CvM_f0quA-E

Test ride around my neighborhood. Figured out my transmission is somehow set up GP style: 1up, 3down. I may switch it. Dunno yet.

Carb is spitting; gotta sort that out.

Clutch is a diaphragm; gonna switch out to heavy springs soon. Currently adjusted too tight; engine stalls when I came to a stop. Yet it slipped on take off, though it *was* second gear.

No electrics hooked up so the tach and speedo aren't working.

Overall I'm super pleased and excited.

GoPro 7 Hero filming
 
721 - 740 of 740 Posts
Top