Suzuki SV650 Riders Forum banner
1 - 13 of 13 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
My sv 650 has fire pump will only work if bypass relay to which at this point the injectors are still not injecting fuel. Bike will start when gas is poured directly into throttle bodies. Man any help would be greatly appreciated. I’m firing to ride the bike. I bought it 3 months ago and changed a lot but still no pulse getting to injectors. Injectors are good I took them out and tested them.
 

· Super Moderator
Joined
·
10,560 Posts
Check for 12v on Y/R (injector power). Y/R comes from the fuel pump relay.

Also, check the fuel fuse.

Is the FI light on in the gauge? Any codes?

Have you ever heard this bike run?

Welcome to SVRider!
 

· Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Check for 12v on Y/R (injector power). Y/R comes from the fuel pump relay. Also, check the fuel fuse. Is the FI light on in the gauge? Any codes? Have you ever heard this bike run? Welcome to SVRider!
When I bought the bike it was not running it had sat up for a year I changed fuel pump fuel pump relay T/o sensor etc yet I’m still having to bypass fuel pump relay for pump to work and I just ran a direct ground to the injector and with relay bypassed and direct ground to injectors the injectors are spitting fuel. So I’m pretty sure this has to be a ecu issue or is there something else I should be looking at?
 

· Registered
DL650AK7
Joined
·
51 Posts
Clutch switch? Crank position sensor wires?
 

· Super Moderator
Joined
·
10,560 Posts
Since the bike runs on raw fuel all safety switches are satisfied.

Try put the bike in Dealer Mode, see if any error codes come up.

You can also try a fuel volume test (should see 6oz in 10 seconds) to be sure the pump is delivering fuel.
 

· Registered
DL650AK7
Joined
·
51 Posts
I’m assuming all that is fine because bike will start when fuel is poured in through throttle body
I thought a bad or unplugged CKP (crank position) sensor cuts fuel so it will crank but not start. Any FI codes?
 

· Registered
Joined
·
4 Posts
Discussion Starter · #9 ·
It'll cut fuel but it'll also cut spark, so since it runs on external fuel supply, it has spark and can't be a bad ckp.
Man I don’t know, it’s throwing f1 code but everything checks out when bypassed to be in perfect working order. I changed fuel pump with what’s supposed to be a compatible pump coil that be the problem because like I said pump won’t even come on unless I bypass the relay
 

· Registered
Joined
·
8,147 Posts
Man I don’t know, it’s throwing f1 code but everything checks out when bypassed to be in perfect working order. I changed fuel pump with what’s supposed to be a compatible pump coil that be the problem because like I said pump won’t even come on unless I bypass the relay
If it works when you bypass the relay then chances are the relay is not being told to turn on in the first place. The question is, why? Is it a sensor issue, computer issue, or is it a broken or shorted wire?
 

· Vendor
Joined
·
222 Posts
Key here might be the bypass of the relay. Signal to the relay must be checked first. There are likely a few things that can interrupt that. The injectors have to have a signal too and that can be checked with a test light while turning engine over.
If there is/was an alarm on the bike....that needs to be unhooked completely.
I suspect an ECU issue...
 
1 - 13 of 13 Posts
Top