Suzuki SV650 Riders Forum banner
1 - 7 of 7 Posts

·
Registered
2000 SV650 N
Joined
·
826 Posts
What's with all of the new single-posters our of South Africa?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Lol. I came here seeking advice because there's only a few Suzuki SV 400s bikes in South Africa. The 650cc Suzuki SV's are more common here seems the 400s Sv bikes are rare here.
 

·
Registered
2000 SV650 N
Joined
·
826 Posts
Nice looking bike (I just painted mine silver). But that sound is scary. I suggest taking it back to the shop that screwed it up.
 

·
Super Moderator
Joined
·
9,174 Posts
Hey guys my brother bought a 400cc Suzuki sv recently. Took it to the workshop to get serviced and came back with a strange ticking noise.
That sounds bad.

Was the bike running before being taken to the shop? If not, maybe the engine was like this already?

Did the shop do a valve adjustment? If not, there is not much the shop could do to cause internal engine damage.

Good luck. Let us know what you find out.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
That sounds bad.

Was the bike running before being taken to the shop? If not, maybe the engine was like this already?

Did the shop do a valve adjustment? If not, there is not much the shop could do to cause internal engine damage.

Good luck. Let us know what you find out.
Yes the bike was running I drove it to the workshop and it had no noises or anything just needed a service. And came back with that strange noise as per the YouTube video that I posted. So I'm hoping to find out what the problem is.
 

·
Super Moderator
Joined
·
9,174 Posts
If they adjusted the valves, the sound could be coming from a problem with the cam chain tensioner(s).
 
1 - 7 of 7 Posts
Top