Suzuki SV650 Riders Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hey so I recently bought my SV650 (used). I took her for a burn lastnight and noticed that the rear brake requires a lot of pressure and is only operating at about 15% ...... no good at all especially in stop and go traffic
The pads are in really good shape still any ideas where I can start trouble shooting ???

Thanks
 

·
site supporter
Joined
·
6,051 Posts
The obvious link between the pads and pedal involves the MC and brake line.
Do you have enough fluid?
Has the brake line been bled?
 

·
Registered
Joined
·
1,180 Posts
Just curious how you landed on the 15% number? And not to start a debate or anything but I rarely use my rear brake in stop and go traffic... Mostly use it for panic stops and such.
 

·
Registered
Joined
·
2,455 Posts
Looks like you'll have to use the dreaded front brakes for that 85% extra brake force. Using the front brake always throws you over the handlebars... Always...

But just bleed your rear brake. If that doesn't work, you'll pry need to get your master cylinder rebuilt since it is a decade old.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
Just curious how you landed on the 15% number? And not to start a debate or anything but I rarely use my rear brake in stop and go traffic... Mostly use it for panic stops and such.
Only reason i use my rear brake in stop and go are the hills and the fact I can't flat foot on either side...as much fun as a hill start with front brake sounds.... As for the 15% its a comparison to the response I was getting from my friends CBR 600 I was riding.

I will try bleeding the brake and changing the fluid. Thanks for the pointers ;)
 
1 - 7 of 7 Posts
Top