Suzuki SV650 Riders Forum banner
1 - 17 of 17 Posts
G

·
Discussion Starter · #1 ·
On my in to work today, I noticed the speedo stuck @ 0mph no matter how fast I went.
(Oh yes, '03 650 BTW)
So of course, 1st thought is the sensor. I turned back around and inspected and washed it off with the hose, just incase there was some piece of funk or metal in there messing with it; no dice.

Is there anything else anyone has ever seen, besides the sensor, that could be wrong? Or, is there an easy way to test the sensor? I guess I'll have to pull it and measure output one way or another - just looking for some info before I go home to get me headstarted.
Thanks all!
Newton
 

·
Premium Member
Joined
·
4,625 Posts
toddpnewton said:
Doh. Suzuki is making more money on me buying parts than the dang bike. Thanks for the info.
Have you ever taken off the front wheel? Even though I've heard of it shredding without ever even touching it, it does seem more common if you remove the rim often, I guess its finicky. I believe its about 15$-20$.
 
G

·
Discussion Starter · #5 ·
evilbologna said:
Have you ever taken off the front wheel? Even though I've heard of it shredding without ever even touching it, it does seem more common if you remove the rim often, I guess its finicky. I believe its about 15$-20$.
Just to swap tires, and not recently. I did park a little too close to my workbench so I thought a stray metal shaving or dust may have gotten underneath it. Blew it out with air so I don't think that's it.

Since it's a common problem I'll bank 25$ and swap it and hope that was it. If not, at least I have a spare.
 

·
Premium Member
Joined
·
4,625 Posts
toddpnewton said:
Since it's a common problem I'll bank 25$ and swap it and hope that was it. If not, at least I have a spare.
Well just pull off your rim and look at it...it'll be uh, kinda obvious if its shredded :)
 

·
Registered
Joined
·
1,461 Posts
dude, what i see is a get out of ticket free card/excuse. Abuse it.
 

·
Hall Monitor
Joined
·
2,762 Posts
lkm said:
dude, what i see is a get out of ticket free card/excuse. 
Hmmm... Call me cynical, but I see a fix it ticket and a moving violation.

Bill
 

·
Registered
Joined
·
91 Posts
Todd Don't just replace sensors and hope for the best. If you have a multi-meter and a little patience you can deduce whether or not it's the sensor. Don't you have a manual?
 
G

·
Discussion Starter · #12 ·
Robotben311 said:
Todd Don't just replace sensors and hope for the best.  If you have a multi-meter and a little patience you can deduce whether or not it's the sensor. Don't you have a manual?
Yeah, but I'm not home yet and it happened to me on the way here - I haven't had a chance to look yet. Didn't know if they had apecific testing method.
If it's an HES I can easily mneasure voltage. If its a coil you can' t really measure with a DMM.
 

·
Registered
Joined
·
476 Posts
mine went out in the rain today as i was coming home. i have an 03 as well. someone at the rally was telling me that his went out in the rain but i forgot what he said to do to fix it.
 

·
Registered
Joined
·
196 Posts
I changed my frt tire this summer and i didnt get it perfectly lined up and after afew days of riding mine was stuck on 0 mph too. It was about an $18 fix from the dealer for the replacent part.
 

·
Registered
Joined
·
476 Posts
abass84 said:
I changed my frt tire this summer and i didnt get it perfectly lined up and after afew days of riding mine was stuck on 0 mph too. It was about an $18 fix from the dealer for the replacent part.
what did you have to do to get it perfectly lined up right? i havn't had my front tire off since august and that was probably 3,000 miles ago at least.
 

·
Registered
Joined
·
196 Posts
There are like three teeth on the piece that is removable, forgive i cant think of its proper name right now, they slip into the opposite in the wheel, just look it over really good and youll do it just fine.
 
1 - 17 of 17 Posts
Top