Suzuki SV650 Riders Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
139 Posts
Discussion Starter #1
Ok so just before Spring Break my speedo started acting funny, bouncing all over the place and sometimes going to zero. Now it is at zero all the time. Has anyone else had this problem? Any ideas?
 

·
Registered
Joined
·
41 Posts
Dackler is 100% right. I had the same problem last spring, get the ring and replace it. You will most likely see the teeth on the ring broke or worn down and no longer spin the sensor.
Very off chance the senor could be bad, but try the ring first, it's a fraction of the cost!
 

·
Registered
Joined
·
139 Posts
Discussion Starter #4
cool. I'll check it when I'm up at work today (I work at a Yamaha *********** :D)
 

·
Registered
Joined
·
801 Posts
This just happened on my 1st gen SVs. I was getting new tires installed, the mech showed me the rotor in the speed sensor was in little pieces so there was no guarantee it would work when he put it back. I found it on line for around 12 bucks and I have a front stand so I should be able to replace it. But how bad is it to take the bike out when the odometer does not count the millage? Is it a big no no?
 

·
BannedCampCounselor
Joined
·
9,911 Posts
But how bad is it to take the bike out when the odometer does not count the millage? Is it a big no no?
If 100% accurate mileage is a concern of yours then I wouldnt do it, but if you have no intentions of selling the bike and reporting accurate mileage, then by all means.....If you do it then just be aware that you should disclose the information to the next owner, should you choose to sell it.
 

·
Registered
Joined
·
801 Posts
Makes sense dackler. I don't plan on selling it, I only have 5 months with it. I'm going to try and fix it or just wait for the new part to replace it. Spank you.
 

·
Registered
Joined
·
1,737 Posts
Wow, one time when Google search pays off.

Last week I was driving home from work when the speedo started bouncing on and off, then totally quit.

Guess it's time to check the sensor... I need to put a new front tire on anyway, and install my Intiminators.
 
1 - 10 of 10 Posts
Top