Suzuki SV650 Riders Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Does anyone know of a good shop to take an SV to that wont charge to much or try and rip me off? I live in Montgomery Co, Maryland

Noticed it stooped working last week when my bike ran out of gas and i was stranded on side of road. Tried fixing it then by reading posts that people with similar problems had. Checked all the stuff... And out of dumb luck it started working but then stooped again, then started up again for about two days. Now that its the weekend I've been without it for 3 days now. I just tried to mess with the wires in the headlight like i did last time but no luck, didn't see anything messed up either.

Basically to make a long story short i need someone else to look at it for me. Any suggestions?
 

·
Registered
Joined
·
10 Posts
Chances are it's your "rotor" for your speed sensor that's the problem. They are apparently made of magnetic guano and disintegrate quite easily. Mine went a year ago and replaced it a couple months ago. The "teeth" or "fins" snap off and turn to dust. Part 15 is what you probably need.

 

·
Registered
Joined
·
283 Posts
But if it's not working, then you're not racking up any miles on the bike.

Hmmmmmmm.

Wrong, yes, but at least you know you're bikes not getting any older. Huh? Don't ask me.

I'm beat to shxt tonite.
 

·
Registered
Joined
·
35 Posts
yup, you have to take off the front wheel. The housing for the sensor will come off also. Just be careful when you put it back together to make sure the lugs mesh or you can easily break it. I greased mine with lithium grease and seems to be holding up for a year now.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top