Suzuki SV650 Riders Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
211 Posts
Discussion Starter · #1 ·
I've got a 2005 SVS650 and the Speedo seems slow, perhaps 10%? I checked the odometer today over 4 miles, and it seemed to be accurate. I'm using the stock front D220 tire. I've read that the speedo is slow, but is possible that the Odometer is accurate? Thanks
 

·
Registered
Joined
·
5,778 Posts
stranger said:
yep. that's the way it is
I thought that generlly the SV speedo was 10% FAST???????? have read that multiple times, and mine is on the '03. The ODO will be off by whatever the speedo is,,,right????
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #4 ·
Oops, brain fade! My speedo reads fast, not slow. 77 mph on the speedo seems to be about 70. However, over a 4 mile test section on a freeway, the odometer seemed spot on. Seems like if I switch to a 70 series front tire for better handling, it will help improve the speedo accuracy, but the odo will become less accurate. Screw it, I am just going to ride the bike.
 

·
Premium Member
Joined
·
11,333 Posts
Morpheous said:
I thought that generlly the SV speedo was 10% FAST???????? have read that multiple times, and mine is on the '03. The ODO will be off by whatever the speedo is,,,right????
no, the mfg's put an error in the speedo cause of some stupid european regulation, odometers are not off
 

·
Registered
Joined
·
571 Posts
also i know for a fact that car manufaturers make their speedos read slightly high so that people cannot use the excuse that the speedo was low when they get pulled over. maybe it is the same for bikes.
 

·
Registered
Joined
·
5,778 Posts
RandyO said:
no, the mfg's put an error in the speedo cause of some stupid european regulation, odometers are not off
Yes correct, and the 10% error is on the fast side, honestly guys.
 
1 - 7 of 7 Posts
Top