Suzuki SV650 Riders Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
152 Posts
Discussion Starter · #1 · (Edited)
So twice in the last two weeks this has happened.

Im cruising along happy as a clam when I go to shift and then **** pedal just falls off. Its still hanging there by the part that goes to the transmission but the part that attaches to the rearset(?) vibrates loose and falls right off.

I cant seem to tighten it enough with the tools in the bag.

Im sure someone else has had this problem. Please give me a fix.

Thanks!
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #6 ·
Sounds like the circlip is missing.
So when I screw it as far in as I can it isnt even sticking out the other side. There is a circlip on the outside holding the pedal to the part that screws.

I dont know my part names very well......
 

·
Registered
Joined
·
125 Posts
I actully had this happen to me on Sunday. I was at a red light and went to go pop into gear and there was nothing there.

I had pointed the culpret to me swapping my shifter out for a busa one because I busted mine in a low speed drop, and I never re-greased the shaft :)

Have many others done this or is it a rarity to have the entire thing pop off?
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #9 ·
Awesome. Ill pick up some blue Loctite next time Im out. Thanks for the info all!

--Ben
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top