Suzuki SV650 Riders Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
409 Posts
Discussion Starter · #1 ·
Just installed a pair of Rizoma Zero 11 tun signals on my 2009 sv650s and am having some issues with blinking rate. Have both resistors hooked up to each signal, per the instructions for a 21W bike (which I believe is in series). Despite this, they are still blinking really fast. Any suggestions?
 

·
Registered
Joined
·
409 Posts
Discussion Starter · #2 ·
Just installed a pair of Rizoma Zero 11 tun signals on my 2009 sv650s and am having some issues with blinking rate. Have both resistors hooked up to each signal, per the instructions for a 21W bike (which I believe is in series). Despite this, they are still blinking really fast. Any suggestions?
Looks like I am not getting any responses here. Time to ask PJ's Parts or the guys at Rizoma. For now I will just leave them at the faster blinking rate, at least it's more noticeable.
 

·
Registered
Joined
·
30 Posts
I have had similar problems with LEDs. The last time I just went to AutoZone and got an EF-32 flasher an spliced it into place. The flasher is made for LEDs and controls the flash rate. the only problem is it doesn't change if a bulb goes out so you need to do your safty checks.
 

·
Premium Member
Joined
·
1,471 Posts
LED flashers for Suzukis are now available on eBay for under $15. No resistors needed and easy swap installation.
 

·
Registered
Joined
·
155 Posts
LED flashers for Suzukis are now available on eBay for under $15. No resistors needed and easy swap installation.
Yeah they're worth a try but I bought 2 of these things from 2 different sellers on ebay and neither of them worked for my zero 11's. They just stayed on with a constant dim brightness and never blinked.

Had to return both of them, I can't don't know why they didn't work.
 

·
Registered
Joined
·
575 Posts
I just run mine fast, seems more noticeable that way to me.
 

·
Registered
Joined
·
409 Posts
Discussion Starter · #8 ·
I just run mine fast, seems more noticeable that way to me.
I would agree, but everything is installed now and running nicely, don't want to mess with it. However, I am sure pulling out a couple resistors would take the flash rate back up.
 

·
Registered
Joined
·
152 Posts
I installed the same signals and like NineseveN, left mine blinking fast too.

Besides, back in the "import racer" days, fast blinkers usually mean you turn faster too ! =]
 

·
Registered
Joined
·
409 Posts
Discussion Starter · #10 ·
I installed the same signals and like NineseveN, left mine blinking fast too.

Besides, back in the "import racer" days, fast blinkers usually mean you turn faster too ! =]
My only concern would be that the faster flash rate would shorten the life of the signals. Some people on here seem to think that without the resistors the LEDs will burn out....Not sure I buy the but whatever, I'm happy as is.
 
1 - 10 of 10 Posts
Top