Suzuki SV650 Riders Forum banner

1 - 7 of 7 Posts
A

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Rear brakes pads replaced about 1000 miles ago, just the last couple of weeks I have been hearing a squeak sound as I apply the rear brakes, up until now there was no noise and the rear brakes worked fine and still do. The noise bothers me.

TM :x
 

·
Registered
Joined
·
6,503 Posts
Easy to fix

I swear, this should be a sticky.

Go to the auto parts store and get some disk brake anti-squeal paste. It comes in a little packet, sort of like ketchup from a fast food restaurant. Remove the pads, put a little of the past where the pads contact the caliper.

While you're at the auto parts store, buy a can of BraKleen or some similar brake cleaning spray. Make sure the surfaces of the pads and the rotor faces are clean.
 

·
Registered
Joined
·
1,461 Posts
i have the same problem. One way i aviod it is not to use the back brake. Esp. when riding with buddies. I have locked it some many times trying to keep from hitting them, now i just swerve.
 

·
Registered
Joined
·
6,503 Posts
Hmmm... let's think about that

The rear brake squeals, so instead of spending about a buck to stop it from squealing just don't use it? Sounds like a bad economy.

Using the rear brake properly does take practice, but it is well worth it.
 

·
Registered
Joined
·
336 Posts
mine is doin the same thing, but i think it's because the metal clip fell out when i put the new tires on and i didnt feel like putin it back in......i just dont use it anyway, unless i need it.
 
1 - 7 of 7 Posts
Top