Suzuki SV650 Riders Forum banner

1 - 9 of 9 Posts
C

·
Guest
Joined
·
0 Posts
Discussion Starter #1
When I was looking at the hose coming out of the radiator I saw it was white. There was some sort of white powdery substance all of the entire hose. I hope I'm just being paranoid and it's normal.

Has anyone else experienced that?
 

·
Registered
Joined
·
8 Posts
Yup, just wipe it down with armor all...it will look good as new. As long as it isn't cracking from age. I think its just oxidation. You can also use S100 Engine bright on them.
 

·
Registered
Joined
·
419 Posts
How's your coolant level? The coolant I use goes in green, and if it leaks, it dries to a very light green, almost white. It is powdery and flakes off fairly easily when dried.
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Thanks for all the input. I'll try that armor all and the coolant I use is green so your right about that. By the way I think my coolant level is too high.
 

·
Registered
Joined
·
42 Posts
someone told me not to use armour all on the rubber hoses on my car... said over time it will make them brittle and prone to cracking. Not sure if it is true, but I have used soapy water instead ever since.
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #7
rwheelz said:
someone told me not to use armour all on the rubber hoses on my car... said over time it will make them brittle and prone to cracking. Not sure if it is true, but I have used soapy water instead ever since.
I heard that also about using armor all on your car dashboard too.
 

·
Registered
Joined
·
8 Posts
Armor all is fine as it contains silicones which actually protect plastic and rubber against UV. Been using it for years without any problems. My hoses were white without any leaks....most likely its just
oxidation.
 
1 - 9 of 9 Posts
Top