Suzuki SV650 Riders Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
850 Posts
Discussion Starter · #1 · (Edited)
R6 Throttle - Not enough cable? [Resolved]

I'm trying to install an R6 throttle tube, but it seems like my cable is too short. I have it adjusted as long as possible but I can barely get it installed, and it seems to be binding (throttle wont return on it's own). Am I missing something?

I'm wondering if a PO might have put some different cables in the bike. Anyone know if there are any visual indicators on the cables?
 

·
Registered
Joined
·
3,546 Posts
Find out where it's binding, most likely it's because those cables are too tight (possible wrong cables) or it's because the tube is binding inside the housing. I installed 3 different ones on my bikes and 1 I had to dremel out the inside of the housing because they were rubbing.
 

·
Registered
Joined
·
850 Posts
Discussion Starter · #3 ·
After a little digging I found the answer:

The cable's are just too short. It appears other's have had this issue on 1st gens (seemed like on the '99's mostly).

Solution: At the carb end of the cable, move both nuts under the bracket. This give's added cable length to play with, and then you can adjust slack at the control end.

You could also pull the cables off the throttle, and put a washer between the 10mm cable "nut" and the bracket - if you think this solution gives too much slack. This will also give better contact area to the bracket. I may try this, but for now the throttle works great.
 

·
Registered
Joined
·
3,546 Posts
Well - you said you adjusted the cables so I assumed you did this on the carb side - that's where most of the adjustment is ;)

If you had said you only adjusted at the handle bar I would have told you to do it at the carb.
 

·
Registered
Joined
·
850 Posts
Discussion Starter · #5 ·
I adjusted the cables, but didn't think to pull the top nut to the other side. :)

It's not technically "right", but it works and there shouldn't be much problem with it.
 
1 - 5 of 5 Posts
Top