Suzuki SV650 Riders Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
So I just ordered a new set of braided Venhill brake lines front and rear, the rears are perfect and nothing is wrong with them. The front lever has no pressure at all but I can still bleed them just fine, there is no air in the lines and they are fully bled but I still have no pressure and no stopping power in the front and I have no clue what it could be. My original thought was that the master cylinder was bad but I have no clue and don't wanna go order something that I'm not sure of, someone please help. :(
 

·
Registered
Joined
·
8 Posts
Discussion Starter #2
Oh and the reason I think it may be the MC is because I emptied all the brake fluid out of the reservoir so it was dry and I probably pulled the brake lever in a few times with no fluid :/ not too sure if that would cause harm
 

·
Registered
Joined
·
12 Posts
There's probably still air in the system. I replaced my OEM lines with some Galfer braided steel lines last month, and was worried I'd messed it up as well.

I got it to work by doing the following:
1. Gravity bleeding each caliper for ~1 hour.
2. Manually bleeding each caliper a few times.
3. Zip tying my brake lever and leaving it overnight to remove any air leftover.

Here's a video I found helpful for my brake line install.

Good luck!
 

·
Registered
Joined
·
40 Posts
rebuilt my mc last month.could not bleed the brakes, last resort got a mighty vac and sucked from the wheel caliper nipple. i think i had a bubble in the master cyl. and needed to push past it.then it built pressure and i could bleed normally
 
1 - 4 of 4 Posts
Top