Suzuki SV650 Riders Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi everyone I'm Greg.Just joined up. I'm a Carpenter by trade.15 years building homes in and around the Seattle area. Now I reside in Tarzana ca.I scored a property management position. I got lucky. Anyway that's enough about me. Guys I need help.I bought this cool Silver Suzuki SV 650 with 16,000 miles on it. Not bad right ? Well I rode it everyday for 3 months..I parked it still warm.I went to start it again and now it just clicks when I hit the starter button.Someone told me to replace the starter relay.So I did that. Still won't start, just clicks. PLease help me out here. Thanks
 

·
Registered
Joined
·
62 Posts
I think you've found your culprit. I'm guessing a charged up new battery is going to have you right as rain.
If you want to prolong the life of the battery, make sure to put it on a battery tender at least once a month if the bike isn't getting ridden often or is only being used for short ~5 minute rides.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
I bought a new battery and still it was clicking when I hit the start button. I was frustrated because I love my bike and not riding it was getting to me. So I checked everything I thought would be a possible cause .Clutch kill switch,kickstand senor and tipover sensor. All fine. Then I remembered I had an intermittent starting problem 3 weeks after I bought it.So I said what the hell and pulled the starter.Tested it with a battery and jumper cables . Guess what it's dead. My bike only has 16,509 miles on it. Is that normal ? I don't know. What do you guys suggest as far as a website to get a starter ? Thanks for all your input.
 

·
Registered
'07 SV650S, '05 Ninja 250
Joined
·
1,033 Posts
You removed the starter and bumped it straight off the battery? And it's a no go? That is odd at such low mileage... I would hit up mad8v here on the site for a used one. Check his inventory.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #13 ·
I bought a new battery and still it was clicking when I hit the start button. I was frustrated because I love my bike and not riding it was getting to me. So I checked everything I thought would be a possible cause .Clutch kill switch,kickstand senor and tipover sensor. All fine. Then I remembered I had an intermittent starting problem 3 weeks after I bought it.So I said what the hell and pulled the starter.Tested it with a battery and jumper cables . Guess what it's dead. My bike only has 16,509 miles on it. Is that normal ? I don't know. What do you guys suggest as far as a website to get a starter ? Thanks for all your input.
Yeah I thought that was unusual too at 16000 miles to replace a starter. It was easy to get to and visually looked fine. But the guy who tested it said that it engages intermittently. I watched as he applied power. It came on. Then died 3 or 4 times. So I'm gonna buy from the website you suggested. Thank you. I need to ride. I'm going crasy seeing it just sitting there.
 
1 - 13 of 13 Posts
Top