Suzuki SV650 Riders Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
My 00SVn has been dying frequently and I'm getting tired of bump starting all the time. There's an indicator on my battery tender that says the battery does not need to be replaced, although I'm not sure how dependable that is. I thought it might be a good idea to replace the stock R/R and ordered a FH008. While waiting for the part to come in, I was looking at the R/R and noticed this lovely surprise while following the stator wires from the R/R.


Can someone tell me if I am correct in thinking that this isn't a big problem since this part of the wiring harness is supposed to be replaced with 12ga wiring direct to the stator? Is this indicative of a bad stator and not the R/R? Is this plug what I've circled on this image or is there another plug closer to the stator?
Of course all this is happening during prime riding season in NY. :facepalm:
 

·
Registered
Joined
·
106 Posts
See: RR mod how-to (svrider.com) and Charging system diagnostic r/r upgrade (eviltwinsbk.com)

Awesome plug!

That kind of short may have taken out the stator or may have grounded itself out via the rectifier or may be unrelated. Definitely replace the plug. There is a difficulty with the 12ga wiring as you can't wire it directly to the stator without much futzing. Best to wire in the 12ga outside the stator case after the gasket and I wired it into the new R/R connector.

Do run the checks to make sure you need to replace the R/R. May not need to replace anything if it's just a connector short that didn't damage anything. Definitely run the tests with the connector removed though.
 
1 - 4 of 4 Posts
Top