Suzuki SV650 Riders Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter #1
So I've been waiting to install a crap ton of stuff for the past month. Now that finals are over i hurried home for me and a buddy to install everything, a clear alternatives smoked tail light, rear tire hugger, hotbodies undertail, K&N air filter, talon full security system, and try out the new stand...

So we start ripping apart the bike, will get pictures up later hopefully, only to realize that motosports sent me the wrong undertail. It looks completely different and says is for 03-05 sv650s, Sh**! So i call them up, they are going to check and make sure that they have one that will fit and reimburse me shipping. Real nice customer support, just wish i didn't have to deal with them :(

Well I still had more to install so I start on the alarm system and use harbor freight connectors i had laying around... bad idea! those things dont hold wire and break! but anyways, got that working gonna install permanently tomorrow. The LED indicator relay was the next one to install, Oh my, i couldn't believe how hard it was to find out which wires i needed. I really need to find a manual :( but after screwing around for a couple hours I found this website. http://www.customdynamics.com/customer_writeup_sv1000_flasher.htm Thank god. So i cut the wires and install it, just a solid light, so i quick change around the wires and it works! woohoo!

Then i go to try out the new tail light, and what do i find? a burnt out LED! gotta call onieda suzuki about that tomorrow and figure out whats that about.

Haven't fit the OEM hugger yet:S with my luck it wont fit either :BangHead:

Wish me luck tomorrow and for a quick turn around from oneida and motosport!
 

·
Registered
Joined
·
919 Posts
Bummer. But it'll all work out in the end. Hang in there. And yes, please do post up pictures.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #4
onieda just told me i have to deal with the manufacturer, oh well guess itll be a shipping frenzy on monday haha.


Heres the precurser to the madness when I thought everything was going to go great! ha


Heres what its at now with the filter in the LED in and the alarm system semi in.


Heres where its going to be for a little while now :(


Will post a better how to on the LED flasher soon and maybe some talon alarm tips who knows.
 

·
Registered
Joined
·
179 Posts
I am in the middle of this myself.. ordered the light from Clear Alternatives directly though. Also had a burnt out LED. They sent me a replacement as soon as I got off the phone, took 2 days to get from Vegas to London Ontario.

You should check out their website, they've also got a flasher installation instruction. :)

While you have all that tore apart you should do the TPS adjustment too, if you haven't already!
 

·
Registered
Joined
·
919 Posts
Sweet man. I can't wait. Sorry you're having to. Someday you'll look back on this and be greatful for this learning experience...

Then again, maybe not.
 

·
Registered
Joined
·
539 Posts
Bro nothing every just works when I am doing mod's I feel your pain!

In the end it is worth it and it feels good knowing you installed the mod's not someone else...

Good Luck!
 

·
Registered
Joined
·
96 Posts
Discussion Starter #8
TPS mod... crap just about forgot about that, haha, Thanks! i'll have to get on that! The lights are super easy to install, especially with the factory harness just have to splice in the indicators with the undertail.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #9
Just did the TPS mod, super easy on the 08's only one screw and its not cheese! woohoo! now if only i had a back end so i could try it out :( haha
 
1 - 9 of 9 Posts
Top