Suzuki SV650 Riders Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter #1
I just adusted my tps and havent noticed any real difference. Mabye the tre i just ordered will help and they will both work together to make the on/off throttle smother. I am looking forward to this cause my wife likes to ride but its hard to be smooth with the bike wanting to lurch all the time. i may just be me but i belive the popping from the pairs is worse now but, it really doesnt bother me.
 

·
Registered
Joined
·
750 Posts
I need to do the TPS myself. Hopefully you will find some relief with that tre.
 

·
Registered
Joined
·
84 Posts
Discussion Starter #3
yeah hope so, i think the fuel should be re-proggramed after all this, it seems like a lot of messing around without telling the computer whats going on. i also wonder what this will due to mpg.
 

·
Premium Member
Joined
·
751 Posts
How far off was it? ie, at what rpm's did the dash move up for your bike?
 

·
Registered
Joined
·
84 Posts
Discussion Starter #5
my idle was good but the line didnt move till about 3800rpm now it moves at about 1500 im still not sure this is something i would suggest i just read about it here and most of the info here seems very reliable. i just havent notice any difference other than what the dash indicated. also it was a very small adjustment so much that the factory white marks still line up for the most part.
 

·
Premium Member
Joined
·
751 Posts
my idle was good but the line didnt move till about 3800rpm now it moves at about 1500 im still not sure this is something i would suggest i just read about it here and most of the info here seems very reliable. i just havent notice any difference other than what the dash indicated. also it was a very small adjustment so much that the factory white marks still line up for the most part.
I haven't done this yet but plan to when I get my aTRE in a month or so. I can't imagine you would notice a whole lot with just doing the tps, in all honesty, this is more of a maintenance thing than a performance mod, you are just setting the tps to what it should've been set at from factory, but they didn't take the time to fine tune it. I think if you pair this with the aTRE is when you really can tell something's been changed. Either way though, even if the butt dyno doesn't tell you that you did anything different, at least you adjusted this to what it was supposed to be at originally. :)
 

·
Registered
Joined
·
84 Posts
Discussion Starter #7
exactly i feel better now that i have done this but as you say it is more of a maint. issue, cant wait for the tre and r6 tube this should take care of everything other than remapping which the dealer said he would do for $80
 

·
Premium Member
Joined
·
751 Posts
Ahh yes, I would like to do the throttle tube this spring as well, not really wanting to order a $9 part and pay $9 for shipping though, I may head to the local dealership and ask them to order one for me.
 

·
Registered
Joined
·
54 Posts
Have you blocked off or removed your Pair valve? My SV1000 had a nasty pop and hesitation and adjusting the TPS, and blocking off the pair valve made it all go away.
 

·
Registered
Joined
·
84 Posts
Discussion Starter #10
i didnt know you could do that, any tips on how, im not to worried about it though because it was already there before cause of the slip on, and to tell you the truth it sounds kinda cool when you are coming to a stop.
 

·
Registered
Joined
·
84 Posts
Discussion Starter #12
thanks for the link, by the way just got back from a ride and im noticing the idle is higher now and the cold start didnt seem to work. i didnt adjust idle before all this because it was inbetween 1 and 1500k.
 
1 - 12 of 12 Posts
Top