Suzuki SV650 Riders Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter · #1 ·
Well, I am on the road, visiting folks in Atlanta. This morning the bike sv650n '08 won't start. To be more exact, it will start but it won't keep running or take throttle. I can hear the feul pumtp when I turn the key.
Full tank of gas.

Any idea on what's wrong

melodie
 

·
Registered
Joined
·
968 Posts
bummer

hot-lanta is quite a trip. maybe your air filter is clogged/boogered up? when it fails does the FI light blink. if it does you should have some error codes that would help you narrow down the problem?

hope you don't get caught in any of this debbie mess if you're planning coming back soon.
 

·
Registered
Joined
·
41 Posts
Take a look at the Throttle Position Sensor (TPS). If the screws on it came loose and it shifted your throttle won't send fuel to the cylinders. Make sure it's plugged tightly into the wiring harness too. You might also check the idle adjustment screw.
 

·
Registered
Joined
·
331 Posts
How's your front spark plug? When I had the SV325 syndrome, it would act like that. I pulled the spark plug boot and added some dielectric grease and she fired right up and kept on running.
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #5 ·
Thanks for the input, ended up with bike towed to dealer after checking everything I could. Failed fuel pump! 700.00 bucks for a new one!!! found one on ebay for 250.00 had it overnighted and the dealer installed it and I am back on my way. The pump must be made out of gold or something.
 
1 - 5 of 5 Posts
Top