Suzuki SV650 Riders Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
340 Posts
Discussion Starter · #1 ·
Hi All,

To anyone with heated grips...where's the best place to mount the toggle switch (if used)? Pics would be great too!

Thanks!
 

·
Registered
Joined
·
2,849 Posts
I put mine on the little replaceable panel on the fairing. sorry no pic.
+1

Plus it makes them very easy to put it and work on if need be. Also if you take them out, that panel is only $11 to replace.

 

·
Registered
Joined
·
100 Posts
Redline, I like that switch. What kind of heated grips are those?

Also, that spot on the fairing is a good spot for those other switches. On my 2000 naked, I had the switch on the left side of the headlight bucket. After installing it, I noticed that if I turned the bars to full lock, some of the cables would sometimes rub across the switch and turn it off or on. I hated when it would turn on high in the summer and start getting hot before I noticed.
 

·
Registered
Joined
·
5,834 Posts
On my naked '01, I bent a 1" wide strip of metal into a square J, put a hole in the bottom, and JB welded it upside down to the right side of my instrument cluster, with the long side facing the clster. Hasn't fallen off, and looks pretty decent. Also painted it black to help it blend in and keep from rusting.
 

·
Registered
Joined
·
262 Posts
Redline, I like that switch. What kind of heated grips are those?
I got Symtec heated grips. Instead of using the switch that came with the kit, I opted instead for a bar mounted switch as pictured above.

You can get it here for $29.95:
http://www.easternbeaver.com/Main/Elec__Products/Switches/switches.html

He also sells a plug and play wiring kit including a relay and inline fuse to wire up your heated grips:
http://www.easternbeaver.com/Main/Products/Heated_Grips/heated_grips.html

:)
 

·
Registered
Joined
·
340 Posts
Discussion Starter · #13 ·
One more question...my plan is to tap into the running light molex wiring (Br and B/W). Is the pos wire the brown one or the black one w/ white stripe?
 

·
Registered
Joined
·
5,834 Posts
Well, post up the answer so that it might help someone that might search this thread later. I just stuck a connector in and it seemed to work, so I don't remember which side was what.
 
1 - 16 of 16 Posts
Top