Suzuki SV650 Riders Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My 2006 SV650S was dropped a few nights ago, All that was damaged was the clutch lever which broke, and the front left turn signal. Right after it dropped I knew it wouldnt start with the clutch lever not pulled in, but turned the key and the fuel pump kicked in fine. I still havnt received my new clutch lever yet, but in trying to trouble shoot to make sure the switch wasnt bad, I turned the ignition to on again. Even with the bike in neutral, and the kick stand down the fuel pump doesnt kick on. I checked all fuses and they are all fine. The Display does say "Chec". Also before I noticed this problem i tried simulating the clutch lever by pulling on the clutch cable and pressing the switch but no dice. Maybe there is something else with the clutch lever that im not thinking of. Anyone with any insight, it would be much appreciated.
 

·
Registered
Joined
·
166 Posts
well, not really sure why the fuel pump does that, i initially thought that since the fuel pump came on the first time you turned it on it had already built up the pressure so that the second time you did it without running it the pressure would still be there and so the pump wouldn't kick on, but then i tried it on mine and wasn't the case, mine's an '04 so maybe they put that on on yours but i kinda doubt it. as far as the clutch thing goes, the interlock is from a microswitch on the lever itself and not the cable, so even if you pull the cable but the lever switch isn't depressed then it still won't work, hope this helps some
 
1 - 2 of 2 Posts
Top