Suzuki SV650 Riders Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey guys, I've been the proud owner of a 2006 Sv650s for about ten years. During some maintenance therapy last month, I changed the oil and spark plugs using the NGK Iridium CR8EIX. This is the first time using these specific plugs--I had heard decent reviews on them and thought I would spend a little extra cash on them. After installing, everything ran smoothly.
About 3-4 days ago, I went for a night ride and began to notice my bike idling funny and an overall loss of power. When I was inspecting it in the morning, the front spark plug boot was not seated. I pushed the boot back in, and felt what I thought was it "seating" and took the bike for a ride when the same problem reoccurred. This has happened multiple times in the last couple of days and was wondering if there was something I could be overlooking, or if it's just something that requires more elbow grease? I had removed and inspected the front spark plug earlier today and noticed that there was a vertical scratch perpendicular with the threads of the spark plug (the threads on the side that the boot covers, not the part that screws into the engine head). Not sure if this is a normal sign wear. Should I just return to using NGK CR8E's?
Thanks for your time!
-Shawn
 

·
Registered
Joined
·
7,185 Posts
Take the boot off and look inside, make sure the wire end is oriented so that it can clip over top of the plug when you push it down. Make sure it isn't mashed from you trying to force it home.
 
1 - 2 of 2 Posts
Top