Suzuki SV650 Riders Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Good day to fellow Sv riders, mechanics , enthusiasts.
I am having an on going problem with my gen 1 sv650s . After going for a ride of about 37 kilometers / 23 miles after stopping for about 30 minutes the bike refuses to start . It will fire however it can no longer hold the rev and it just cuts off.
In addition to this upon a cold start the idle does almost cut out but doesn’t but when the bike is warm it idles correctly.
I have broken down 3 times as a result of this and my local Suzuki dealer keeps draining my fuel and running carb cleaner through the carbs however it always seems to have the same result of me braking down.
Can anyone help me ? I have videos of the bike idling with the problem as well as a clarity of what is happening.
Regards Bradley 0833212130
 

·
Registered
Joined
·
789 Posts
First thing I would check is when the engine stops try opening the fuel cap. It has been known for the vents to block and cause a partial vacuum preventing fuel flow.

Then use the forum search or a search engine for SV650 stuck Choke Plungers as they can cause this kind of problem
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
After riding the home from work this afternoon, the bike performed perfectly however I have tried to start it after 2 hours and it doesn’t want to start . If I attempt to start it in another 2 hours then it will start hence I suspect it’s maybe particles suspending in the fuel system when it’s warm and settles after cooling down then it starts but I am no mechanic hence me seeking advice.
I will open the fuel cap the next time I start it and revert back . Thank you for your advice.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Good day to one and all,

Att: Straticus : I have tried opening the fuel cap however at this point when the bike starts it will idle for about 6 seconds and then just die off. When I try to start it again, the neutral light dims and it will not turn on as I press the button. Note the battery is about 3 months old so it’s almost new.

Please help...?
 
1 - 4 of 4 Posts
Top