Suzuki SV650 Riders Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter · #1 ·
Well finally got the bike put back together after making my diy fender eliminator, new battery was finally delivered, and front master cylinder rebuilt. Starts right up but idles low, around 900-1000. Rode it 15 feet and pulled the clutch lever and revved it to about 7K RPM and released the throttle and the bike died. No biggie, neutral restart and go. Also I have no rear brake, guess I'll be tackling that next. Got gas and on the way home hit a couple of stops. Man this bike does not roll on the slow power smoothly. You give it a little turn of throttle and it wants to surge. Hard to smoothly roll on the throttle in first. Have read about power not coming on till 3K RPM I think in anther post, will have to look into that. Also will have to adjust the idle. Other than that and the slight annoyance of the fuel pump whine, hope that is normal, its a nice little bike.
 

·
Registered
Joined
·
726 Posts

·
Registered
Joined
·
1,726 Posts
I recently adjusted mine. It was set to 3800pm. It made a huge difference adjusting it down to around 1500rpm. I also ordered the TRE that was linked by BLind. It hasn't come in yet, but with as big of a difference as the TPS adjustment made, I'm looking forward to installing it.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #8 ·
So far I have just adjusted the idle as my rear brake is under repair. But it did make a big difference upping the idle as it doesn't sound like its going to stall when I rev it up and the rpms drop back down to idle.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top