Suzuki SV650 Riders Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Hi All,

Trying to figure out wtf is going on with my 03 sv. Installed tail light and blinkers. Turn left signal works. Turn right signal blinks the tail lights like hazards. Hazard button works fine though.
Is this a hot wire issue? Perhaps fuse?
TIA
 

·
Super Moderator
Joined
·
8,605 Posts
Hi panda,
Can you provide more info please?

When you hit the right turn signal switch, does the license plate light flash along with the tail light?

Is the rear brake light functioning OK?

Does the right turn signal light go on at any other time except when the hazard switch is turned on? From your description it sounds like the right turn switch just makes the tail light flash.

Finally, are your newly installed lights original equipment or aftermarket? Why were the lights removed in the first place? Did you install new front blinkers as well as rear?

It sounds like you just have some wires crossed, and with enough information shouldn't be hard to straighten out.

-TeeRiver
 

·
Registered
Joined
·
32 Posts
Discussion Starter #4
Hi TeeRiver,

Thanks for the reply. I bought a wrecked '03 sv July of 08. Kick me in the ass for finally wanting to fix it now! The rear was wrecked, so the rear blinkers are pretty much gone... decided to go with an integrated tail light (cheap ebay version without resistors and prongs only for the positive lead, no ground). Well, I pulled out the integrated tail and worked on the stock tail and managed to fix the blinker sockets. Inserted the bulbs and tested out the controls:

1. Upon ignition - license plate light turns on without any blinks or flashes
2. Hazards - blinks the tail light and signals only.
3. left turn signal - left blinker works
4. right turn signal - right blinker works

I think i wired the integrated tail light incorrectly... after reading bottlerocketdodger's thread, the two wire feeds for the blinkers are black and light green. However, I hooked up light brown as a blinker (which is actually the license plate light). After hooking up the two blinkers, the tail light works correctly. So you were correct... i crossed the wires myself!

Thanks all.
 
1 - 5 of 5 Posts
Top