Suzuki SV650 Riders Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Hey All:

I just picked-up a 2003 SV650N that I needed to convert from the Veypor back to a the OEM gauge for my sister (her bike). I found a 2006 gauge and 2008 speedo sensor. The speedo reads high not quite 2x except maybe at low speeds but I believe this would be a speedo magnet issue. I would think that the '06 and '08 would be the same but likely not? Should I go ahead and order an '06 speedo magnet or do I need to consider anything else to get this speedo accurate.

Thanks for any insights!
Dave
 

·
Premium Member
Joined
·
3,729 Posts
It should be obvious if you have the correct sender magnet - there is factor of two difference i.e. 30mph would be displaying 60.
The sensor/gauge changed in 2008 so 2008 sensor is indeed incompatible with the 2006 gauge.
So yes, you need new magnet from 2003-2007.

Speedo will still be about 10% but this is 'normal'
- if you want it accurate, you need a speedo healer (actually if you buy a speedo healer you can get by with the sensor you have without replacing it also, as you can calibrate to it regardless)
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
Thanks for the confirmation. I was having a bit of trouble trying to see if the part#s matched for the magnet since all of the microfiches show the same 4 prong without the factory part #s. Bikebandit did check that the part #s are indeed different so I've ordered the '06 magnet. Ironic thing was that the '03magnet that came with the bike was all crushed and not turning properly so I thought there was another issue. Checked my cleaned and greased '08 magnet and it sits properly and spins nicely. Thanks again! -Dave
 
1 - 3 of 3 Posts
Top