Suzuki SV650 Riders Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
192 Posts
Discussion Starter · #1 ·
HELP ME PLEASE!! i havent been able to get my bike to start since tuesday.. i charged the battery and nothing...added fuel and nothing..Is it STILL flooded?.. is the fuel pump f'd or not hooked up? this blows
 

·
Registered
Joined
·
2,749 Posts
Is the starter engaging? As in is it trying to turn over or is it completely dead?
 

·
Registered
Joined
·
92 Posts
drudru said:
got it... vaccum house on fuel pump was not on property and now im off to work
Where is the vaccum pump, maybe that is what's wrong with mine?
 

·
Registered
Joined
·
136 Posts
its not a pump...
its just a hose that comes off the carbs... on first gens...
it connects to the fule cock...
under the tank on the left rear... you should see 2 hoses going to the fule cock.. one big hose is for fule... the other is for vacume to suck the fule outa the tank.. and the 2 wires are for the fule light...
 

·
Registered
Joined
·
397 Posts
SVnaKidRider said:
its not a pump...
its just a hose that comes off the carbs... on first gens...
it connects to the fule cock...
under the tank on the left rear... you should see 2 hoses going to the fule cock.. one big hose is for fule... the other is for vacume to suck the fule outa the tank.. and the 2 wires are for the fule light...
Check page 4-9,4-10 of the service manual to see the fuel pump.
 

·
Registered
Joined
·
6,503 Posts
Yep, there's a vacuum operated pump as well as the vacuum petcock. This is the first time I heard of a fuel pump vacum hose coming loose.
 

·
Registered
Joined
·
136 Posts
whoooh.
theres a fule pump...
going to have to check that out in the moring... i didnit know that...
we are talking about first gens correct?
 

·
Registered
Joined
·
397 Posts
Yes
 

·
Registered
Joined
·
192 Posts
Discussion Starter · #10 ·
the PO got the tank painted.. and i guess the line wasnt put back on quite right... i started it, burned up all the fuel in the line and then it took a few days to think about it... HOWEVER i did have to take of the airbox and shoot a little starter fluid into the carbs to get her back going...
 
1 - 10 of 10 Posts
Top