Suzuki SV650 Riders Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
Ok, sO i picked up my 03 copper SV650S on Saturday and have been riding this weekend. First bike and all, having tons of fun. Question though- My back turn signals arent working. I turn them on and you can't see shit blinking. Is this a fuse or what? Yes I am a girl and dont know much about this kinda of thing yet. Im guessing that is the only place the blinkers would be is in the brake lights also. So any advice would be greatly appreciated!
 

·
Registered
Joined
·
20 Posts
are the front ones working? And if so, are they flashing at a rapid rate? For cars i know if they flash fast it means you have a burnt out bulb....probably the same for motorcycles. Also, the blinkers aren't actually IN the brake lights unless they're integrated.
 

·
Registered
Joined
·
703 Posts
If you're guessing that the turn signals are in the brake light, then I'm guessing that they've been removed as part of a fender elimination. Unless of course you have a Clear Alternatives brake light. Best chance for getting a quick answer is to grab a digital camera and take some pictures of the bike. This way people will know if the bike's had a mod done, and what type of mod it is.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #4
Alright thanks for the advice. I do believe there has been a fender eliminator put on so that may be why. I will try to get some pictures when I get home.
 
1 - 4 of 4 Posts
Top