Suzuki SV650 Riders Forum banner
1 - 7 of 7 Posts

·
Premium Member
Joined
·
11,333 Posts
Discussion Starter · #1 ·
went to replace my "broken cable' and discovered the clutch release mechanism split at the cable holder allowing the cable to pop out. going to try lassoing it together with a mini hose clamp untill the new part comes

just corrosion and use over 123k, can't complain
 

·
Premium Member
Joined
·
4,625 Posts
at 123k I think pretty much anything could happen...
 

·
Eagle one
Joined
·
1,660 Posts
Like I said Randy......... just a reality check........ before you invest a lot of money in the suspension........ you might want to look for a bike with 100,000 less miles on it........
 

·
Premium Member
Joined
·
11,333 Posts
Discussion Starter · #4 ·
67GTONUT said:
Like I said Randy......... just a reality check........ before you invest a lot of money in the suspension........ you might want to look for a bike with 100,000 less miles on it........
if I get another bike, it will have 123k less miles on it
 

·
Registered
Joined
·
2,196 Posts
RandyO said:
just corrosion and use over 123k, can't complain
In my case, it was a loosened front sprocket which caused the chain to rub this very part (nearly) through. You might have a look in that direction, too.

Ciao
Jan
 

·
Premium Member
Joined
·
11,333 Posts
Discussion Starter · #7 ·
Jan Zoellner said:
In my case, it was a loosened front sprocket which caused the chain to rub this very part (nearly) through. You might have a look in that direction, too.

Ciao
Jan
no, where this broke is nowwhere near the sprocket, it would have to damage the cable first, just plain worn out, cable is fine, sprocket is tight
 
1 - 7 of 7 Posts
Top