Suzuki SV650 Riders Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
I have a 2003 sv1000, it was stolen and I got it recovered! the complete bike torn into a bunch of pieces, I decided to put it back together, i now have the whole bike back together but I cant get it to start. the starter motor turns, and it seems like the bike wants to start but I cant get it to actually fire over. I am wondering if anyone has any ideas of what this could be?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
yes my FI light flashes, i have everything plugged in, and you can hear the fuel pump working.
 

·
Registered
Joined
·
4,657 Posts
Did you happen to replace the ignition switch?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
yes, the bike was a theft recovery, so we replaced the ignition switch with a universal one for now until the real one shows up in the mail.
 

·
Registered
Joined
·
4,657 Posts
yes, the bike was a theft recovery, so we replaced the ignition switch with a universal one for now until the real one shows up in the mail.
There is a resistor in the SV switch and the bike won't start without it- It is a theft prevention measure.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #7
thanks for that, it makes sense that it is in there. are the 650 and 1000 the same switch?
 

·
Registered
Joined
·
4,657 Posts
thanks for that, it makes sense that it is in there. are the 650 and 1000 the same switch?
Probably. You can cross reference the part numbers on Ronayers.com
 

·
Registered
Joined
·
4,657 Posts
do you know where to get one online?
ronayers.com or oneidasuzuki.com

You could also just wire in the correct resistor- but I don't know the value off hand. Try searching for race harness ignition resistor and you'll probably find it.
 
1 - 12 of 12 Posts
Top