Suzuki SV650 Riders Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-12 of 12 Results
  1. Motorcycle Talk
    Hi SV lovers,I have a heating problem on my SV650A 2018 model, it cuts out for about 2 seconds, screen goes off, then it is back as if nothing happened. If it is very hot, this can happen every 10 or 20 seconds, switching the ignition on and off, causes a delay of about 1 minute to next cut...
  2. SV650 Gen3 (17-...) Tech
    Hi SV lovers,I have a heating problem on my SV650A 2018 model, it cuts out for about 2 seconds, screen goes off, then it is back as if nothing happened. If it is very hot, this can happen every 10 or 20 seconds, switching the ignition on and off, causes a delay of about 1 minute to next cut...
  3. SV650 Gen1 (99-02) Tech
    My bike died while riding like I hit the kill switch, I've tried everything from bypassing the kick stand switch, clutch switch, changing starter relay, new r/r, starter maintenance and checked green connector. When I try to start it the button does nothing, when key is turned to on position I...
  4. Motorcycle Talk
    Hi guys, Hopefully this will be me overlooking something in front of my nose - 2009 SV650S. Stock indicators were dying and corroded (note that the indicators stopped working before changing to LEDs - even the dash arrows weren't lighting up). Bought some online along with a 7-pin LED relay...
  5. Electrical
    2001-2002 SV650S (Partial Fairings) *Initial break down **What works been done since ***What's going on now *So this is a new one for me in 30 years. My bike stopped working last summer and I had to have it trailered home. There seems to be some confusion on what happened- I thought I'd been...
  6. Electrical
    Hey guys, need some help here. Replaced the battery and ignition switch and now the bike has no power. Main fuse pops every time I turn the ignition to ON or PARK. The battery reads 12.6V. Voltmeter shows I have voltage at the 10 amp meter fuse, 30amp main fuse, and the red wire at the ignition...
  7. Electrical
    I recently purchased aftermarket turn signals for my 99' SV because my left signal was burnt out. When I was wiring up the new signals in the front, I shorted the left signal by touching the positive and neutral crimps together. I was too excited to see if they worked before I taped them. Now...
  8. Motorcycle Talk
    I've hade a lot of battery/starter problems with my 1st gen. When the battery was drained while riding I realised it was generator problems. The r/r was dead which I have replaced now. So I think the generator problems have been sorted. Now the battery wont run the starter even when fully...
  9. SV650 Gen1 (99-02) Tech
    Just bought an 02' SV. Currently sorting through the bike, but I can't figure out where this connector is supposed to go and what it is for.
  10. Electrical
    Hi there, I have been riding my 2014 ABS model Gladius for some 2 years, on an A2 license. The seller told me the bike was restricted upon purchase, hence I was able to ride it on my license. I will soon be looking to take my A license, and would like to do it on my Gladius, which means me...
  11. SV650 Gen2 (03-15) Tech
    Anybody feel like helping out....joined up hoping someone would but yeah here are the details so far... Background: 05 SV650s, had bike for 4 months everything worked awesome except for the occasional loose bolt here and there but i 've got those all snugged up with some blue lock-tite n proper...
  12. SV650 Gen1 (99-02) Tech
    Hello, I was trying to go through a few other threads on this same issue, but I didn't want to hijack; especially when some of them are over a decade old. Recently picked up another SV650 (Naked this time) to kill time during the lock-down, that is beating my behind trying to get to run and...
1-12 of 12 Results
Top