Suzuki SV650 Riders Forum banner

electrical issues

  1. Electrical issue on my 2001 sv650

    SV650 Gen1 (99-02) Tech
    Electrical I need help! Jump to LatestUnfollow 1 - 1 of 1 Posts mxwllneidigh Registered Joined 1 h ago · 1 Posts Discussion Starter • #1 • 1 h ago Okay, so I recently purchased a 2001 sv650 and everything was fine. Old battery but the thing ran and did everything it was supposed to...
  2. I need help!

    Electrical
    Okay, so I recently purchased a 2001 sv650 and everything was fine. Old battery but the thing ran and did everything it was supposed to. Fast forward about 3 weeks, battery took a dump, We jumped it at a gas station, the low beams were off, the tach wasn't reading at all, and the speedo was only...
  3. ‘07 SV650 high/low beams + high beam indicator not working

    Electrical
    A couple days ago I rode my SV home and stopped to say hello to a friend. I cut power to the engine, but left the lights on for 5 minutes. Standing next to the bike I noticed the lights shut off and they wouldn’t turn on when started. Additionally, the high beams indicator disappeared as well...
  4. 2003 Sv650s sometimes won't start

    Electrical
    Hey so this is my problem. It started last fall, my bike would having trouble starting, and if I didn't ride it for a few days it wouldn't start at all. I replaced the battery this spring but the issue remains. For example. I could go for a ride in Monday, but if I don't start it again until...
  5. No power, none, zilch

    SV650 Gen2 (03-15) Tech
    I have a 2004 650, and it's been sitting for several months because my starter clutch went out and I haven't had the extra funds to buy one. I had a friend wanted to see what it did when you cranked it. So I turned it on, everything normal, hit the starter button, heard a pop, and power left...
  6. 05 SV650s Hi-beams aren't working

    SV650 Gen2 (03-15) Tech
    Anybody feel like helping out....joined up hoping someone would but yeah here are the details so far... Background: 05 SV650s, had bike for 4 months everything worked awesome except for the occasional loose bolt here and there but i 've got those all snugged up with some blue lock-tite n proper...
  7. 2001 - SV650 No Spark

    SV650 Gen1 (99-02) Tech
    Hello, I was trying to go through a few other threads on this same issue, but I didn't want to hijack; especially when some of them are over a decade old. Recently picked up another SV650 (Naked this time) to kill time during the lock-down, that is beating my behind trying to get to run and...
  8. Electrical Problem

    SV650 Gen1 (99-02) Tech
    I have a 2000 SV650 with an apparent electrical issue. My bike sat for over a year and the battery was dead so I replaced it. I push the starter button and the bike starts, but the starter will not disengage. I turn off the key... starter still spinning. The only way to disengage the starter...
  9. 2004 Sv650 dies at idle and when given throttle

    SV650 Gen2 (03-15) Tech
    Hi, my name is Sean and I just recently got a motorcycle (June last year) to commute to and from campus for school. It's a 2004 SV650 with 21.4k miles on it (34.4k km). Over winter break I didn't ride my bike very much and it sat in the garage for probably 2 or 3 weeks. I turned it on every...
  10. Bike does not want to start (solved)

    SV650 Gen2 (03-15) Tech
    // I had a video of my second start attempt but as a new user I am not allowed to include links. I would try to include it in the next post Hello fellow SV riders! I have an issue starting my bike but I know it could be very hard to diagnose a problem over the internet so I will try to be as...
Top