Bike Won't start-FI light and C42 error code - Page 2 - Suzuki SV650 Forum: SV650, SV1000, Gladius Forums

Go Back   Suzuki SV650 Forum: SV650, SV1000, Gladius Forums > Workshop > SV650 Gen2 (03-15) Tech
New User? Register - Forgot Password
Register Forums FAQ Gallery Members List Calendar Search Today's Posts Mark Forums Read Motorcycle EscrowInsurance Advertise

SV650 Gen2 (03-15) Tech Info, advice or questions specific to the 2003-2015 model SV650.

Reply
 
Thread Tools Display Modes
Old 04-13-2010, 09:34 PM   #11
PatrickE
Senior Member
 
PatrickE's Avatar
 
Join Date: Sep 2008
Location: Little Rock, AR
Bikes: KTM Duke 690
Posts: 1,164
Re: Bike Won't start-FI light and C42 error code

Quote:
Originally Posted by [email protected] View Post
Anyone have a link or can walk me through removing the left side fairing that runs to the tail? I'm hung up right now at the tail cap.
Download a manual it covers that. Plus, it will come in handy in the future.
__________________
SV Hadder
PatrickE is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-07-2016, 07:51 PM   #12
jgvapfc
Junior Member
 
Join Date: Oct 2015
Bikes: Norton 750
Miles Kms: 8000
Posts: 3
Re: Bike Won't start-FI light and C42 error code

greetings SV world, I have an 07 SV650S I picked up at an Insurance Auction. The front end was mangled, but not too bad, the ignition switch was hanging broken/no key. I turned the ignition switch with a pair of pliers, and with a jump it started right up (with no instrument cluster) I swapped out the front end ( 07 GSX-R) cut the old ignition switch away and put a new battery in. Now it won't start. It turns over and will run as long as you feed the air box with starter fluid. I took the inst cluster off my 06 and put it in Dealer Mode. I get a c42 error code...Ignition Switch Anti Theft. It does not appear to be a true ignition problem because it does start and run if you squirt and keep squirting starter fluid in the air box.

I read through the thread re c42 from back in 09...anyone have any new info ideas?

02 SV650 race bike, 06 SV road worthy, 07 SV being prepped as Race back-up, 73 Norton 750 Commando, 75 Triumph 750 Trident, 78 BMW R-100/5, 2003 Ducati Multistrada 1000DS, 2005 Suzuki BR-Z400
jgvapfc is offline   Reply With Quote
Old 05-07-2016, 10:31 PM   #13
TeeRiver
Moderator

 
TeeRiver's Avatar
 
Join Date: Mar 2009
Location: SoCal
Bikes: '03N, '07N
Miles Kms: ~44/gal
Posts: 7,910
Re: Bike Won't start-FI light and C42 error code

Quote:
Originally Posted by jgvapfc View Post
... cut the old ignition switch away and put a new battery in. Now it won't start.
Something went wrong there. Either a damaged switch or wires. The bike will not run if C42 error code is showing. Fixing that is step number one.

Take a look at DEcosse's post above, it is good advice. Post back if you need more help.
__________________
The truth will set you free... but first it will pis you off! -anon
TeeRiver is offline   Reply With Quote
 
Old 05-09-2016, 11:18 AM   #14
r0ckrat
Greetings Program
 
r0ckrat's Avatar
 
Join Date: Jun 2013
Location: Long Beach
Bikes: '06 SV650N
Miles Kms: >60k
Posts: 6,270
Re: Bike Won't start-FI light and C42 error code

Isn't there a resistor in the switch for anti-theft?
__________________
Dory - a blue K6 Naked, lives again. Build thread and Comment thread - also The SV Colors Compendium
Quote:
Originally Posted by Fatass SVS View Post
I didn't want to be THAT obvious. The man is dealing with his wife. Let it be her idea, dummy!
r0ckrat is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
05 sv650 fi error- code is c42 ryan1clancy SV650 Gen2 (03-15) Tech 6 02-29-2016 10:05 PM
C42 error code BIGBUGIN SV1000 (03-07) Tech 7 12-29-2014 09:02 AM
FI light - error code c32 jreiter SV650 Gen2 (03-15) Tech 10 08-07-2013 08:55 AM
FI Light C42 Error red6rdr SV650 Gen2 (03-15) Tech 1 06-18-2010 07:36 PM
Error code C42 in dealer mode sbbsnewman SVRider Motorcycling Forum 2 03-12-2009 12:46 PM


All times are GMT -5. The time now is 03:03 PM.


Design Developed by CompleteGFX
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
1999-2009 SVRIDER.com.
Motorcycle News, Videos and Reviews
Honda Grom Forum strong>Kawasaki Z125 Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Honda Africa Twin Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum Ducati 959 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Victory Charger Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum
BMW Scrambler Forum Ducati Scrambler Forum Kawasaki Ninja 250SL Forum
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.