Bike Won't start-FI light and C42 error code - Suzuki SV650 Forum: SV650, SV1000, Gladius Forums

Go Back   Suzuki SV650 Forum: SV650, SV1000, Gladius Forums > Workshop > SV650 Gen2 (03-15) Tech
New User? Register - Forgot Password
Register Forums FAQ Gallery Members List Calendar Search Today's Posts Mark Forums Read Motorcycle EscrowInsurance Advertise

SV650 Gen2 (03-15) Tech Info, advice or questions specific to the 2003-2015 model SV650.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-13-2010, 11:12 AM   #1
[email protected]
Junior Member
 
Join Date: Jun 2008
Bikes: SV650
Miles Kms: 6000
Posts: 4
Bike Won't start-FI light and C42 error code

Replaced the shock on an 04 naked.

Had to cut the battery box and push it back along with the ECM.

Now bike won't start and flashed FI. No fuel injection whirl when I turn the key, but starter turns over. Put it in dealer mode and C42 kicks out (Ignition switch)

Check about every electrical connection and nothing loose or disconnected. Fuses are fine. The ignition switch worked before the shock switch. The kill switch is off, but if I flip it on, the display will change to "CHEC". Poked around and some threads suggested a bunch of things to do to the ignition switch (squirting cylinder with WD40 and turning the key on/off, disconnect battery etc). Nothing worked.

Only think I can think of is I had to put a battery charger on the battery and tried to started it with it connected (set to 6 AMPs at the time). Hoping I didn't fry something, but if I did, I need pointers on where to look and how to find it.

I'm an electrical retard, so I can use any help anyone can lend.
erikhamel@hotmail.com is offline   Reply With Quote
Sponsored Links
Advertisement
 
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
05 sv650 fi error- code is c42 ryan1clancy SV650 Gen2 (03-15) Tech 6 02-29-2016 11:05 PM
C42 error code BIGBUGIN SV1000 (03-07) Tech 7 12-29-2014 10:02 AM
FI light - error code c32 jreiter SV650 Gen2 (03-15) Tech 10 08-07-2013 09:55 AM
FI Light C42 Error red6rdr SV650 Gen2 (03-15) Tech 1 06-18-2010 08:36 PM
Error code C42 in dealer mode sbbsnewman Motorcycle Talk 2 03-12-2009 01:46 PM


All times are GMT -5. The time now is 08:30 AM.


Design Developed by CompleteGFX
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
1999-2009 SVRIDER.com.
Motorcycle News, Videos and Reviews
Honda Grom Forum strong>Kawasaki Z125 Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Honda Africa Twin Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum Ducati 959 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Victory Charger Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum
BMW Scrambler Forum Ducati Scrambler Forum Kawasaki Ninja 250SL Forum
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.