No Spark - Suzuki SV650 Forum: SV650, SV1000, Gladius Forums

Go Back   Suzuki SV650 Forum: SV650, SV1000, Gladius Forums > Workshop > SV650 Gen1 (99-02) Tech
New User? Register - Forgot Password
Register Forums FAQ Gallery Members List Calendar Search Today's Posts Mark Forums Read Motorcycle EscrowInsurance Advertise

SV650 Gen1 (99-02) Tech Info, advice or questions specific to the 1999-2002 model SV650.

Reply
 
Thread Tools Display Modes
Old 07-09-2019, 06:05 AM   #1
ru.5.ty
Junior Member
 
ru.5.ty's Avatar
 
Join Date: Jul 2019
Location: SCOTLAND
Bikes: SV650 K1
Miles Kms: 2500
Posts: 1
Exclamation No Spark

Hi all, new on this.

I've recently ran into some electrical problems with my SV650 K1.

Bike just died at a junction to which I found the starter solenoid plug had come loose. The top half had actually broken off. Replaced and all electrics worked fine but the bike won't start now. It turns strongly but still no spark.

I then noticed that the headlight, sidelight and 1 tail light had all blown. (after trying to start it a few times) This lead me to think it could be the side stand switch as the positive feed from the switch feeds these lights. Replaced side stand switch and still no spark.

I've checked the coils and getting correct resistance readings from coil and HT leads. I've check all the fuses and all look in good condition. Killswitch works as it should, battery is holding charge, there is no visible damage on the stator, spark plugs have been replaced.

I've bought a new Cdi unit which hopefully will fix this issue but if it doesn't, is there anywhere else I can look? I've checked over all wiring to and from the Cdi unit and power is definitely getting to the coils.

Starting to run out of ideas other than going back over everything again.

Any help would be appreciated.

Thanks
ru.5.ty is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:38 PM.


Design Developed by CompleteGFX
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
1999-2009 SVRIDER.com.
Motorcycle News, Videos and Reviews
Honda Grom Forum strong>Kawasaki Z125 Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Honda Africa Twin Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum Ducati 959 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Victory Charger Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum
BMW Scrambler Forum Ducati Scrambler Forum Kawasaki Ninja 250SL Forum
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.