fuel pump not turning on (wiring issue) - Suzuki SV650 Forum: SV650, SV1000, Gladius Forums

Go Back   Suzuki SV650 Forum: SV650, SV1000, Gladius Forums > Workshop > SV650 Gen2 (03-15) Tech
New User? Register - Forgot Password
Register Forums FAQ Gallery Members List Calendar Search Today's Posts Mark Forums Read Motorcycle EscrowInsurance Advertise

SV650 Gen2 (03-15) Tech Info, advice or questions specific to the 2003-2015 model SV650.

Reply
 
Thread Tools Display Modes
Old 06-27-2019, 09:16 PM   #1
spectastic
Member
 
Join Date: Aug 2014
Bikes: 03 sv650s
Miles Kms: 26k
Posts: 158
fuel pump not turning on (wiring issue)

my sv currently can't start because the fuel pump isn't turning on. things I've tried:

1. the engine turns, so it's not a faulty kill switch
2. fuel pump relay is good
3. the fuses look good
4. fuel pump works when hooked up directly to battery
5. when I turn ignition, I hear the relay clicking. however, I don't hear the injectors or the fuel pump.

based on all this, I'm guessing the wiring is bad. any ideas?

btw. I'm ok with mechanical stuff. when it comes to electrical stuff, I'm more challenged, so if you have ideas, please explain it as you would to a 3rd grader.
spectastic is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-27-2019, 10:07 PM   #2
tovar
Senior Member
 
tovar's Avatar
 
Join Date: Jul 2009
Bikes: mali tovar
Posts: 6,432
Re: fuel pump not turning on (wiring issue)

tos
tovar is offline   Reply With Quote
Old 06-28-2019, 12:31 AM   #3
spectastic
Member
 
Join Date: Aug 2014
Bikes: 03 sv650s
Miles Kms: 26k
Posts: 158
Re: fuel pump not turning on (wiring issue)

Quote:
Originally Posted by tovar View Post
tos
well it's pointing up like it's supposed to.
spectastic is offline   Reply With Quote
 
Old 06-28-2019, 12:34 AM   #4
tovar
Senior Member
 
tovar's Avatar
 
Join Date: Jul 2009
Bikes: mali tovar
Posts: 6,432
Re: fuel pump not turning on (wiring issue)

Tip over sensor.
tovar is offline   Reply With Quote
Old 06-28-2019, 02:05 AM   #5
spectastic
Member
 
Join Date: Aug 2014
Bikes: 03 sv650s
Miles Kms: 26k
Posts: 158
Re: fuel pump not turning on (wiring issue)

Quote:
Originally Posted by tovar View Post
Tip over sensor.
can you put that in a sentence?

the bike was laid down, but the tip over sensor doesn't look like its out of place. are you suggesting the ring inside might be stuck to one side or something?
spectastic is offline   Reply With Quote
Old 06-30-2019, 07:29 AM   #6
spectastic
Member
 
Join Date: Aug 2014
Bikes: 03 sv650s
Miles Kms: 26k
Posts: 158
Re: fuel pump not turning on (wiring issue)

bump
spectastic is offline   Reply With Quote
Old 07-01-2019, 03:07 PM   #7
marteney1
Member
 
Join Date: Sep 2018
Location: Austin, TX
Bikes: '07 SV650S
Miles Kms: 21k
Posts: 37
Re: fuel pump not turning on (wiring issue)

Hey, it's Drew. You figure it out? Maybe need a new TOS, or maybe try to pull the TOS and plug a paperclip in both sides to short the circuit as a diagnostic? Or maybe leave if off, not sure if the circuit needs to be open or closed to run. If that doesn't work, like I said, I'd just run a fused wire from the hot side of the battery to a switch, and then to the fuel pump + wire on the bike side of the plug.
marteney1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:04 PM.


Design Developed by CompleteGFX
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
1999-2009 SVRIDER.com.
Motorcycle News, Videos and Reviews
Honda Grom Forum strong>Kawasaki Z125 Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Honda Africa Twin Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum Ducati 959 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Victory Charger Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum
BMW Scrambler Forum Ducati Scrambler Forum Kawasaki Ninja 250SL Forum
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.