Installed some new parts, have some questions: - Suzuki SV650 Forum: SV650, SV1000, Gladius Forums

Go Back   Suzuki SV650 Forum: SV650, SV1000, Gladius Forums > Workshop > SV650 Gen2 (03-15) Tech
New User? Register - Forgot Password
Register Forums FAQ Gallery Members List Calendar Search Today's Posts Mark Forums Read Motorcycle EscrowInsurance Advertise

SV650 Gen2 (03-15) Tech Info, advice or questions specific to the 2003-2015 model SV650.

Reply
 
Thread Tools Display Modes
Old 02-14-2008, 07:08 AM   #1
gtramontelli
 
Join Date: Jul 2007
Posts: 89
Installed some new parts, have some questions:

Hi,

I just did the first 2 mods to my 2007 SV650N. This week I installed the hotbodies undertail and a set of motosliders. I have some questions, though. First, I was very careful to keep all of my parts in order when installing the undertail. I take all of my nuts/bolts/screws and put them in a solo cup so that I won't lose them. There are 2 screws that hold together the plastic between the 2 seats, and I swear my bike only had the lower one. Anyway, I reinstalled everything, and that area has a little play in it now. It doesn't seem to move unless you specifically touch it, but I'm not really sure I like that it moves at all. Anyone else ever find that fasteners were missing when changing things?

Secondly, my blinkers are flashing very quickly, and I know that a resistor can fix that. However, I almost think that the quick blink is more noticeable. Is there anything illegal about having the fast flash?

3rd, with the motosliders, the instructions give a torque spec for installation. I didnt have a torque wrench, so I just estimated. I also used locktite as instructed. Any problem if I overtightened it a bit?

Thanks.
gtramontelli is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-14-2008, 07:48 AM   #2
fluke323
Senior Member
 
fluke323's Avatar
 
Join Date: Sep 2006
Location: Rockland County NY
Bikes: 2002 SVS/N Creamcycle, 2003 XR 50, 1964 Honda Dream 150, 1970 Honda CB 175
Posts: 2,541
Send a message via AIM to fluke323
Re: Installed some new parts, have some questions:

1) Did you get your bike new or used? Mine was used, so I'm sure that was the reason that several nuts and washers were missing.

2) No, not in NY anyway. People usually just like to have the regular speed because it can get annoying and on some bikes (not the sv to my knowledge) will show a sensor problem because its not drawing enough current.

3) I'd worry more about under tightening than over tightening because it is an engine mount bolt. As long as you didn't strip the nut, I'm sure it will be fine.
__________________
TDTM Motorsports#95 ////// White-Lightnin' Squad ///// Storm Thumper
Quote:
Originally Posted by ASCSurveyor View Post
Yeah, but if it wasn't for "Captain C--kblock to the rescue!", methinks the outcome may have been different.
fluke323 is offline   Reply With Quote
Old 02-14-2008, 09:31 AM   #3
gtramontelli
 
Join Date: Jul 2007
Posts: 89
Re: Installed some new parts, have some questions:

I got it new.

Thanks for the info about the flashers and the motosliders. I guess I will see if there is a way for me to rig the plastics so they are more stable. I just hope i dont have to take too much apart again lol.

Thanks again.
gtramontelli is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New 'round these parts. Upgraded from 250R and have some questions Heirfaus Introduce Yourself 5 03-22-2013 04:07 AM
I have installed some bad race fairings, but this takes the cake. Shane Liberty SV650 Gen2 (03-15) Tech 11 03-09-2011 10:12 AM
Got some parts, now I got some questions... Integra505 Motorcycle Talk 11 08-13-2010 11:02 PM
Motosliders installed :D some questions... R-Razor Motosliders Board 2 03-22-2008 03:04 PM
Thinking of sv1000, have sv650 have some questions Jon Mueller Motorcycle Talk 14 08-16-2005 09:22 PM


All times are GMT -5. The time now is 04:19 PM.


Design Developed by CompleteGFX
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
1999-2009 SVRIDER.com.
Motorcycle News, Videos and Reviews
Honda Grom Forum strong>Kawasaki Z125 Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Honda Africa Twin Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum Ducati 959 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum
Yamaha Motorcycles Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum
BMW Scrambler Forum Ducati Scrambler Forum
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.