2nd dead stator in 2 months. HELP! - Suzuki SV650 Forum: SV650, SV1000, Gladius Forums

Go Back   Suzuki SV650 Forum: SV650, SV1000, Gladius Forums > Workshop > SV650 Gen1 (99-02) Tech
New User? Register - Forgot Password
Register Forums FAQ Gallery Members List Calendar Search Today's Posts Mark Forums Read Motorcycle EscrowInsurance Advertise

SV650 Gen1 (99-02) Tech Info, advice or questions specific to the 1999-2002 model SV650.

Reply
 
Thread Tools Display Modes
Old 08-13-2019, 11:21 AM   #1
wilit
Junior Member
 
Join Date: May 2017
Bikes: 2001 SV650
Miles Kms: 5000
Posts: 5
2nd dead stator in 2 months. HELP!

Bike is an '01 with 45k-ish miles. Back in May of 2017, I upgraded to a MOSFET RR and wired the RR direct to the battery through a 30A breaker and 12ga wire. March of this year, the bike quit charging while I was riding it. After doing a post mortem on the system, it turns out I was most likely using a eBay clone RR and not a true MOSFET. The stator was toast as was the breaker. Testing the MOSFET after replacing the stator, it's most likely it went bad as I was getting 17v out of the system. I'm guessing it overtaxed the stator and it cooked it.

I replaced the stator with a good used one, replaced the breaker with the same style, but different brand and used a true Shindengen FH020AA RR off of a CBR500R. Everything seemed great until yesterday, go to leave for work and I noticed it wasn't charging (I have a volt meter on the bike). I checked the breaker first since it's the easiest component to get to, and it wasn't tripped and it is functioning correctly and has continuity through it. I'll do some more testing tonight once I get the tail off, but I'm guessing it's probably the stator again.

Any ideas on what's causing this? The first one I had attributed to the clone RR, but now I'm wondering if maybe there's another issue. In both failures, the breaker didn't trip, so I'm guessing that it may not be the issue? I don't know. Also, any recommendations on where to get a stator? I'm really hesitant to buy a new OEM one as they're $300+ and I don't want that burning up too.
wilit is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-13-2019, 03:28 PM   #2
Straticus
Senior Member
 
Straticus's Avatar
 
Join Date: Feb 2017
Location: JAMOADR
Bikes: 1999 X naked Curvy
Miles Kms: 24,000
Posts: 762
Re: 2nd dead stator in 2 months. HELP!

I have a pet hate of the Block connectors.Checkout my Mosfet Upgrade page,

https://cx500.000webhostapp.com/Mosf...sfetUniRR.html

It may not be the problem but a bad block connector can cause shorts and ruin stators.
__________________
https://www.youtube.com/watch?time_c...&v=xmOo_AhyJJU
"The pessimist complains about the wind; the optimist expects it to change; the realist adjusts the sails."
Straticus is offline   Reply With Quote
Old 08-13-2019, 03:59 PM   #3
wilit
Junior Member
 
Join Date: May 2017
Bikes: 2001 SV650
Miles Kms: 5000
Posts: 5
Re: 2nd dead stator in 2 months. HELP!

Quote:
Originally Posted by Straticus View Post
I have a pet hate of the Block connectors.Checkout my Mosfet Upgrade page,



It may not be the problem but a bad block connector can cause shorts and ruin stators.
Not trying to be a dick, but literally the 2nd sentence of my post is saying that I upgraded to a MOSFET and eliminated the block connectors by wiring direct to the battery.
wilit is offline   Reply With Quote
 
Old 08-13-2019, 04:28 PM   #4
Straticus
Senior Member
 
Straticus's Avatar
 
Join Date: Feb 2017
Location: JAMOADR
Bikes: 1999 X naked Curvy
Miles Kms: 24,000
Posts: 762
Re: 2nd dead stator in 2 months. HELP!

Quote:
Originally Posted by wilit View Post
Not trying to be a dick, but literally the 2nd sentence of my post is saying that I upgraded to a MOSFET and eliminated the block connectors by wiring direct to the battery.
No problem but I wasn't sure if you had eliminated the two from the Stator to the R/R.Just trying to find the fault for you so you don't lose another Stator
__________________
https://www.youtube.com/watch?time_c...&v=xmOo_AhyJJU
"The pessimist complains about the wind; the optimist expects it to change; the realist adjusts the sails."
Straticus is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:19 PM.


Design Developed by CompleteGFX
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
1999-2009 SVRIDER.com.
Motorcycle News, Videos and Reviews
Honda Grom Forum strong>Kawasaki Z125 Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Honda Africa Twin Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum Ducati 959 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum
Yamaha Motorcycles Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum
BMW Scrambler Forum Ducati Scrambler Forum
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.