Suzuki SV650 Forum: SV650, SV1000, Gladius Forums

Suzuki SV650 Forum: SV650, SV1000, Gladius Forums (https://www.svrider.com/forum/forums.php)
-   SV650 Gen2 (03-15) Tech (https://www.svrider.com/forum/forumdisplay.php?f=17)
-   -   Faulty horn. (https://www.svrider.com/forum/showthread.php?t=395509)

limweikiat1 10-07-2019 03:34 PM

Faulty horn.
 
Good afternooN all,

I'm here again because my horn has been giving me issues, I've changed from stock to denali mini horn and also this happens when i had stock, hence the change.

After the change it still happens sometimes, when i press no horn but a click sound. But sometimes it does horns, also, i've cleaned out my buttons on the switch ( opened completely and cleaned )

Please advise.

GeorgeRYoung 10-07-2019 03:51 PM

Re: Faulty horn.
 
If your brake lights work, the fuse #5 (signal) is ok.

There's a connector for the Left Handlebar, maybe poor connection on either the O/G (hot) or B/W (gnd).

golden chicken 10-07-2019 06:32 PM

Re: Faulty horn.
 
I had to sandpaper the carbon off the switch contacts. There's a decent amount of current going through the switch in order to sound the horn and mine burnt slightly.

limweikiat1 10-08-2019 02:03 AM

Re: Faulty horn.
 
Signal lights are working,
so i need to sand the wires?

golden chicken 10-08-2019 06:58 PM

Re: Faulty horn.
 
Not exactly.

When you open the switch body you want to sand the places that touch when you press the horn button. They're not wires so much as two copper colored strips of metal.


All times are GMT -5. The time now is 05:40 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
1999-2009 SVRIDER.com.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.