2005 SV650S Will NOT start...what am I doing wrong - Suzuki SV650 Forum: SV650, SV1000, Gladius Forums
 
Suzuki SV650 Forum: SV650, SV1000, Gladius Forums

Go Back   Suzuki SV650 Forum: SV650, SV1000, Gladius Forums > Workshop > 03 + SV650 Tech
New User? Register - Forgot Password
Register Forums Garage FAQ Gallery Members List Calendar Search Today's Posts Mark Forums Read Motorcycle EscrowInsurance

03 + SV650 Tech Info, advice or questions specific to the 2003-up model SV650.

Reply
 
Thread Tools Display Modes
Old 05-24-2011, 08:15 PM   #1
jrob36109
Junior Member
 
Join Date: May 2011
Bikes: Suzuki SV650S
Miles Kms: 6871
Posts: 4
2005 SV650S Will NOT start...what am I doing wrong

Okay....so I am sure it has been answered before and I am probably looking over it. I have a 2005 SV650S that has been sitting up for about 10 months while I was overseas (military) and I thought I was smart in draining the tank before leaving out. Now that I am back, I put gas back in it, a new battery, new spark plugs and thought that would be enough....I was wrong. I talked to a few motorcycle mechanics and they told me to try putting some sea foam in the tank...well....it hasn't worked either. When I turn the key on I do not hear the pump priming. I have no idea if it is clogged or not. I am trying to avoid paying $300+ a pump if I can avoid it. ANYONE PLEASE HELP!!!!!
jrob36109 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-24-2011, 08:19 PM   #2
snatfinder
Senior Member
 
snatfinder's Avatar
 
Join Date: Nov 2005
Location: Tucson
Bikes: RSVR Factory / r6(track)
Posts: 2,219
Re: 2005 SV650S Will NOT start...what am I doing wrong

Kill switch, clutch switch, main fuse
__________________
Quote:
Originally Posted by VARIABLE9 View Post
Good luck with the new SV Luis, anxiously awaiting the next ride report.
snatfinder is offline   Reply With Quote
Old 05-24-2011, 08:26 PM   #3
HardcoreKeith
Senior Member
 
Join Date: Mar 2010
Bikes: Suzuki SV650
Miles Kms: 37,000
Posts: 347
Re: 2005 SV650S Will NOT start...what am I doing wrong

Yep. ^^ A lot of the time it's just a corroded kill switch. Flick it back and forth until the fuel pump starts whining.
HardcoreKeith is offline   Reply With Quote
Old 05-24-2011, 08:49 PM   #4
RedRaptor22
Senior Member
 
RedRaptor22's Avatar
 
Join Date: Jul 2008
Location: Baton Rouge, Louisiana
Bikes: Was a nakified 07 650, Now is 12 Xr650L
Miles Kms: 9700
Posts: 3,276
Re: 2005 SV650S Will NOT start...what am I doing wrong

This may sound stupid but i've seen this happen to at least 5 customers this spring...did you fill the new battery with acid and charge it?

If so, what the others said, it's probably not the pump.
__________________
Your a doody head, with a poo poo face and a smelly butt!
RedRaptor22 is offline   Reply With Quote
Old 05-25-2011, 12:10 AM   #5
jrob36109
Junior Member
 
Join Date: May 2011
Bikes: Suzuki SV650S
Miles Kms: 6871
Posts: 4
Re: 2005 SV650S Will NOT start...what am I doing wrong

Okay...not to sound like a total idiot...the kill switch is the one located above the started button....correct? If it is, then I have try flipping it over and over and still no luck. I did get it to fire by spraying some starter fluid into the top of the throttle body, but with it not getting fuel from the tank it didn't run long.
jrob36109 is offline   Reply With Quote
Old 05-25-2011, 01:57 AM   #6
TeeRiver
Titanium Member
 
TeeRiver's Avatar
 
Join Date: Mar 2009
Location: SoCal
Bikes: '03N, '07N
Miles Kms: ~44/gal
Posts: 5,888
Re: 2005 SV650S Will NOT start...what am I doing wrong

Welcome to SVR jrob!

The SV's fuel pump should run for 3 seconds as soon as the key is truned on, but if that's not happening, sitting dry for 10 months may have seized it. Was everything OK before sitting?

Here are some easy things to try:
- Make sure the 10A fuel fuse is OK.
- Put your hand on the fuel pump relay and see if you feel it click when you first turn the key on.
- If you do feel a click but the fuel pump doesn't run, use a voltmeter to check for 12v on the Yellow/Red wire at the fuel pump relay; again, look during the first 3 seconds.

If all that checks out, but still no fuel pump prime, then the final test is connect power and ground directly to the fuel pump connector. Connect battery ground to the Black/White (ground), and battery 12v to the Yellow/Red (power) pump connector pins. If that fails to run the pump, then it's seized.

If the pump is seized, then maybe try add 1/2 gallon of fuel to the tank (don't fill it all the way up), and add a can of seafoam, let that sit, then repeatedly apply power over and over to the pump connector try to break it loose. Good luck!
__________________
The truth will set you free... but first it will pis you off! -anon
TeeRiver is offline   Reply With Quote
Old 05-25-2011, 09:38 AM   #7
Jay V
Supporting Member
 
Jay V's Avatar
 
Join Date: Apr 2006
Location: WI
Bikes: '06 SVn, '00 SVn project
Posts: 5,104
Re: 2005 SV650S Will NOT start...what am I doing wrong

I think TeeRiver has the procedure you need to solve the problem.

For future reference, you always want a steel tank full of fuel (w/stabilizer) for storage. That eliminates air-space that will cause condensation and rust. I even go as far as adding 1 oz per gal of 2-stroke oil to the tank before storage. You also want to do an oil change as the last thing just before putting it away, and run the engine only about 10 seconds with the fresh oil before storing. Never start an engine up over the winter to warm it up - it only adds moisture and contaminants to the clean oil.

Let us know what you find out.

Thanks for serving.


Jay
Jay V is offline   Reply With Quote
Old 06-26-2011, 08:34 PM   #8
jrob36109
Junior Member
 
Join Date: May 2011
Bikes: Suzuki SV650S
Miles Kms: 6871
Posts: 4
Re: 2005 SV650S Will NOT start...what am I doing wrong

Okay....sorry for being away so long....was out of town. I wound up trying all of the suggestions and.....no luck. I think the pump is dead. Anyone know what I would need to do to rebuild the fuel pump, or where I can get a pump on the cheap? Someone told me that some of the Suzuki and Yamaha fuel pumps can be replaced with a Ford F150 fuel pump assembly? Anyone else ever heard this one before? I really want to avoid spending $600 for a fuel pump.
jrob36109 is offline   Reply With Quote
Old 08-24-2011, 02:17 PM   #9
dcamco
Junior Member
 
Join Date: Aug 2011
Bikes: 05 SV650
Miles Kms: 23000
Posts: 12
Re: 2005 SV650S Will NOT start...what am I doing wrong

Bump, I'm curious about this too..
dcamco is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:46 AM.


Design Developed by CompleteGFX
1999-2009 SVRIDER.com.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum Kawasaki Ninja 250SL Forum

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.